Project

General

Profile

action #56540

openQA Tests - action #15132: [saga][epic] Better structure of test plans in main.pm

action #44360: [epic] Parameterize test suites within job groups

action #55730: [epic] Move parameters from test suites into job groups

convert staging job groups to YAML

Added by okurz 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Organisational
Target version:
Start date:
2019-09-06
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Motivation

Someone decided it's a good idea to ditch the old web UI editor for job groups hence we need to switch all job groups to YAML. Doing that for staging "ourselves", I mean within the QA tools team, might give us some feedback that we can learn from.

History

#1 Updated by cdywan 10 months ago

I picked up Staging: SLE 12 and I agree it's proving to be insightful.

#2 Updated by cdywan 10 months ago

It's worth noting products like Installer-DVD-Staging:B are rejected by the JSON schema, wheras we also have Staging-B-DVD, so I just went ahead with renaming products using a colon (:).

#3 Updated by cdywan 10 months ago

I further more took over Staging: SLE 15 and Staging: CaasP.

#4 Updated by cdywan 10 months ago

I became aware that the related progress wasn't added here, so I'm retroactively documenting this effort:

rsync_sle.pm had to be adapted to account for renamed products:

  • Server-DVD-Staging:A -> Server-DVD-A-Staging
  • Installer-DVD-Staging:A -> Installer-DVD-A-Staging

The filename for the scheduling YAML for autoyast had to be fixed since it fell out of the naming pattern.

SLE 12 SP5 has failures right now. I hadn't much success so far tracking down the root cause.

  • Staging variants of tests were replaced with regular tests in the YAML, instead defining settings in-place.
  • YAML_SCHEDULE: schedule/staging/%TEST%@%MACHINE%.yaml is apparently not expanded correctly and the filename can contain the wrong machine.

Right now I'm looking into working around the expansion issues to get things back to a working state and not block on a fix.

#5 Updated by lkocman 10 months ago

Just to note that actual conversation about current SLE-12 staging reviews with autobuild resulted into Coolo pointing back to this ticket. So it seems fully in your hands.
The conversation was started to ensure that issues are not on autobuild side.

#6 Updated by cdywan 10 months ago

See #56876 for the fix of the failures mentioned above.

#7 Updated by coolo 9 months ago

  • Status changed from New to In Progress
  • Assignee set to cdywan
  • Target version set to Current Sprint

This is done, no?

#8 Updated by cdywan 9 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF