Project

General

Profile

action #55511

job failed to revert to lastgood snapshot "Could not open backing file: Could not open '/var/lib/openqa/pool/2/….iso': No such file or directory"

Added by okurz about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2019-08-14
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://openqa.opensuse.org/tests/1006939/file/autoinst-log.txt shows an incomplete:

[2019-08-14T12:56:38.848 CEST] [debug] <<< testapi::type_string(string=' ; echo yHJVf-$?- > /dev/ttyS0
', max_interval=250, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
[2019-08-14T12:56:39.604 CEST] [debug] <<< testapi::wait_serial(buffer_size=undef, quiet=undef, regexp=qr/yHJVf-\d+-/, no_regex=0, timeout=90, expect_not_found=0, record_output=undef)
[2019-08-14T12:58:10.787 CEST] [debug] >>> testapi::wait_serial: (?^:yHJVf-\d+-): fail
[2019-08-14T12:58:10.787 CEST] [debug] post_fail_hook failed: command 'curl --form upload=@problem_detection_logs.tar.xz --form upname=firefox-problem_detection_logs.tar.xz http://10.0.2.2:20023/t_ioDpGSscjieIOE/uploadlog/problem_detection_logs.tar.xz' timed out at /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/lib/opensusebasetest.pm line 138.

[2019-08-14T12:58:10.789 CEST] [debug] Loading a VM snapshot lastgood
[2019-08-14T12:58:10.790 CEST] [debug] Loading snapshot (Current VM state is running).
[2019-08-14T12:58:10.794 CEST] [debug] EVENT {"event":"STOP","timestamp":{"microseconds":793988,"seconds":1565780290}}
[2019-08-14T12:58:10.795 CEST] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2019-08-14T12:58:12.873 CEST] [debug] QEMU: qemu-system-x86_64: terminating on signal 15 from pid 30807 (/usr/bin/isotovideo: backen)
[2019-08-14T12:58:12.874 CEST] [debug] running /usr/bin/qemu-img create -f qcow2 -b /var/lib/openqa/pool/2/raid/hd0-overlay10 /var/lib/openqa/pool/2/raid/hd0-overlay11 10G
[2019-08-14T12:58:12.905 CEST] [debug] Formatting '/var/lib/openqa/pool/2/raid/hd0-overlay11', fmt=qcow2 size=10737418240 backing_file=/var/lib/openqa/pool/2/raid/hd0-overlay10 cluster_size=65536 lazy_refcounts=off refcount_bits=16
[2019-08-14T12:58:12.905 CEST] [debug] running /usr/bin/qemu-img create -f qcow2 -b /var/lib/openqa/pool/2/raid/usbstick-overlay10 /var/lib/openqa/pool/2/raid/usbstick-overlay11 974782464
[2019-08-14T12:58:12.933 CEST] [debug] qemu-img: warning: Could not verify backing image. This may become an error in future versions.
Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open '/var/lib/openqa/pool/2/openSUSE-Tumbleweed-KDE-Live-x86_64-Snapshot20190813-Media.iso': No such file or directory
Formatting '/var/lib/openqa/pool/2/raid/usbstick-overlay11', fmt=qcow2 size=974782464 backing_file=/var/lib/openqa/pool/2/raid/usbstick-overlay10 cluster_size=65536 lazy_refcounts=off refcount_bits=16
[2019-08-14T12:58:12.933 CEST] [debug] running /usr/bin/qemu-img create -f qcow2 -b /var/lib/openqa/pool/2/raid/pflash-code-overlay10 /var/lib/openqa/pool/2/raid/pflash-code-overlay11 1966080
[2019-08-14T12:58:12.961 CEST] [debug] Formatting '/var/lib/openqa/pool/2/raid/pflash-code-overlay11', fmt=qcow2 size=1966080 backing_file=/var/lib/openqa/pool/2/raid/pflash-code-overlay10 cluster_size=65536 lazy_refcounts=off refcount_bits=16
[2019-08-14T12:58:12.961 CEST] [debug] running /usr/bin/qemu-img create -f qcow2 -b /var/lib/openqa/pool/2/raid/pflash-vars-overlay10 /var/lib/openqa/pool/2/raid/pflash-vars-overlay11 131072
[2019-08-14T12:58:12.989 CEST] [debug] Formatting '/var/lib/openqa/pool/2/raid/pflash-vars-overlay11', fmt=qcow2 size=131072 backing_file=/var/lib/openqa/pool/2/raid/pflash-vars-overlay10 cluster_size=65536 lazy_refcounts=off refcount_bits=16
[2019-08-14T12:58:12.990 CEST] [debug] starting: /usr/bin/qemu-system-x86_64 -only-migratable -chardev ringbuf,id=serial0,logfile=serial0,logappend=on -serial chardev:serial0 -soundhw ac97 -global isa-fdc.driveA= -m 2048 -cpu qemu64 -netdev user,id=qanet0 -device virtio-net,netdev=qanet0,mac=52:54:00:12:34:56 -device usb-ehci -device usb-tablet -smp 1 -enable-kvm -no-shutdown -vnc :92,share=force-shared -device virtio-serial -chardev pipe,id=virtio_console,path=virtio_console,logfile=virtio_console.log,logappend=on -device virtconsole,chardev=virtio_console,name=org.openqa.console.virtio_console -chardev socket,path=qmp_socket,server,nowait,id=qmp_socket,logfile=qmp_socket.log,logappend=on -qmp chardev:qmp_socket -S -device virtio-scsi-pci,id=scsi0 -device usb-ehci,id=ehci0 -blockdev driver=file,node-name=hd0-overlay11-file,filename=/var/lib/openqa/pool/2/raid/hd0-overlay11,cache.no-flush=on -blockdev driver=qcow2,node-name=hd0-overlay11,file=hd0-overlay11-file,cache.no-flush=on -device virtio-blk,id=hd0-device,drive=hd0-overlay11,serial=hd0 -blockdev driver=file,node-name=usbstick-overlay11-file,filename=/var/lib/openqa/pool/2/raid/usbstick-overlay11,cache.no-flush=on -blockdev driver=qcow2,node-name=usbstick-overlay11,file=usbstick-overlay11-file,cache.no-flush=on -device usb-storage,id=usbstick-device,drive=usbstick-overlay11,bootindex=0 -drive id=pflash-code-overlay11,if=pflash,file=/var/lib/openqa/pool/2/raid/pflash-code-overlay11,unit=0,readonly=on -drive id=pflash-vars-overlay11,if=pflash,file=/var/lib/openqa/pool/2/raid/pflash-vars-overlay11,unit=1 -incoming defer
[2019-08-14T12:58:12.999 CEST] [debug] Waiting for 0 attempts
[2019-08-14T12:58:13.106 CEST] [debug] Waiting for 1 attempts
[2019-08-14T12:58:14.106 CEST] [debug] Waiting for 2 attempts
[2019-08-14T12:58:15.107 CEST] [debug] Waiting for 3 attempts
[2019-08-14T12:58:16.107 CEST] [debug] Waiting for 4 attempts
[2019-08-14T12:58:17.108 CEST] [debug] Waiting for 5 attempts
[2019-08-14T12:58:18.108 CEST] [debug] Waiting for 6 attempts
[2019-08-14T12:58:19.108 CEST] [debug] Waiting for 7 attempts
[2019-08-14T12:58:20.109 CEST] [debug] Waiting for 8 attempts
[2019-08-14T12:58:21.109 CEST] [debug] Waiting for 9 attempts
[2019-08-14T12:58:22.109 CEST] [debug] Waiting for 10 attempts
[2019-08-14T12:58:23.110 CEST] [debug] Waiting for 11 attempts
[2019-08-14T12:58:24.110 CEST] [debug] Waiting for 12 attempts
[2019-08-14T12:58:25.110 CEST] [debug] Waiting for 13 attempts
[2019-08-14T12:58:26.111 CEST] [debug] Waiting for 14 attempts
[2019-08-14T12:58:27.111 CEST] [debug] Waiting for 15 attempts
[2019-08-14T12:58:28.112 CEST] [debug] Waiting for 16 attempts
[2019-08-14T12:58:29.112 CEST] [debug] Waiting for 17 attempts
[2019-08-14T12:58:30.112 CEST] [debug] Waiting for 18 attempts
[2019-08-14T12:58:31.113 CEST] [debug] Waiting for 19 attempts
[2019-08-14T12:58:32.113 CEST] [debug] Backend process died, backend errors are reported below in the following lines:
can't open qmp at /usr/lib/os-autoinst/OpenQA/Qemu/Proc.pm line 405.

[2019-08-14T12:58:32.113 CEST] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2019-08-14T12:58:32.117 CEST] [debug] flushing frames
last frame
[2019-08-14T12:58:32.144 CEST] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2019-08-14T12:58:32.146 CEST] [debug] QEMU: QEMU emulator version 3.1.0 (openSUSE Leap 15.1)
[2019-08-14T12:58:32.146 CEST] [debug] QEMU: Copyright (c) 2003-2018 Fabrice Bellard and the QEMU Project developers
[2019-08-14T12:58:32.146 CEST] [debug] QEMU: qemu-system-x86_64: -blockdev driver=qcow2,node-name=usbstick-overlay11,file=usbstick-overlay11-file,cache.no-flush=on: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open '/var/lib/openqa/pool/2/openSUSE-Tumbleweed-KDE-Live-x86_64-Snapshot20190813-Media.iso': No such file or directory
[2019-08-14T12:58:32.146 CEST] [debug] sending magic and exit
[2019-08-14T12:58:32.147 CEST] [debug] received magic close

Related issues

Is duplicate of openQA Project - action #46742: test incompletes trying to revert to qemu snapshot auto_review:"Could not open backing file: Could not open .*.qcow.*No such file or directory", likely premature deletion of files from cacheResolved2019-01-282020-02-18

Copied to openQA Project - action #55514: job failed to lastgood snapshot "Could not open backing file: Could not open backing file: Could not open …"Rejected2019-08-14

History

#1 Updated by okurz about 2 years ago

  • Assignee set to rpalethorpe

Hi Richi, as you are the qemu snapshot expert, could you take a look into that?

#2 Updated by okurz about 2 years ago

  • Copied to action #55514: job failed to lastgood snapshot "Could not open backing file: Could not open backing file: Could not open …" added

#3 Updated by asmorodskyi about 2 years ago

https://openqa.suse.de/tests/3258786 - another example of same issue

#4 Updated by okurz about 2 years ago

  • Is duplicate of action #46742: test incompletes trying to revert to qemu snapshot auto_review:"Could not open backing file: Could not open .*.qcow.*No such file or directory", likely premature deletion of files from cache added

#5 Updated by okurz about 2 years ago

  • Status changed from New to Rejected
  • Assignee changed from rpalethorpe to okurz

Also available in: Atom PDF