Project

General

Profile

action #54464

qemu-img convert failed

Added by jadamek over 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2019-07-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

I had the issue just below with two workers (openqaworker7 and 6):

[2019-07-18T16:24:32.567 CEST] [debug] qemu-img: Could not open '/var/lib/openqa/pool/11/raid/hd0-overlay8': Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open backing file: Could not open '/var/lib/openqa/pool/11/sle-12-SP4-x86_64-ha-alpha-alpha-node01.qcow2': No such file or directory

This is not the first time I see this message, perhaps it's a known issue.

I know that other poo are opened for openqaworker7 (poo#54074 and poo#49694) but I'm not aware of any for openqaworker6.

List of failed tests:
worker 6 https://openqa.suse.de/tests/3090100
worker 6 https://openqa.suse.de/tests/3088928
worker 7 https://openqa.suse.de/tests/3087514

The test was re-triggered by a POST command and was ok in openqaworker9.
worker 9 https://openqa.suse.de/tests/3092394

I see poo#54128 as well but looks like different.

worker6-1.autoinst-log.txt (625 KB) worker6-1.autoinst-log.txt jadamek, 2019-07-19 10:14
worker6-2.autoinst-log.txt (633 KB) worker6-2.autoinst-log.txt jadamek, 2019-07-19 10:14
worker7-1.autoinst-log.txt (626 KB) worker7-1.autoinst-log.txt jadamek, 2019-07-19 10:14

Related issues

Is duplicate of openQA Project - action #46742: test incompletes trying to revert to qemu snapshot auto_review:"Could not open backing file: Could not open .*.qcow.*No such file or directory", likely premature deletion of files from cacheResolved2019-01-282020-02-18

History

#1 Updated by jadamek over 2 years ago

Actually, this issue seems to be not related to specific workers at all.
New errors with the last build '0103@0248':

https://openqa.suse.de/tests/3157016 ==> openqaworker9:12
https://openqa.suse.de/tests/3157020 ==> openqaworker8:21
https://openqa.suse.de/tests/3156008 ==> openqaworker7:18
https://openqa.suse.de/tests/3156011 ==> openqaworker6:16
https://openqa.suse.de/tests/3156980 ==> openqaworker8:8
https://openqa.suse.de/tests/3156085 ==> openqaworker7:7
https://openqa.suse.de/tests/3156083 ==> openqaworker13:9

#2 Updated by okurz over 2 years ago

  • Is duplicate of action #46742: test incompletes trying to revert to qemu snapshot auto_review:"Could not open backing file: Could not open .*.qcow.*No such file or directory", likely premature deletion of files from cache added

#3 Updated by coolo about 2 years ago

  • Project changed from openQA Infrastructure to openQA Project
  • Subject changed from qemu-img convert failed in some workers to qemu-img convert failed

#4 Updated by okurz about 2 years ago

  • Category set to Concrete Bugs
  • Status changed from New to Rejected
  • Assignee set to okurz
  • Target version set to Done

then we can actually close it as the duplicate it is.

Also available in: Atom PDF