action #53486

[tools] test fails in openqa_webui - reproducibly fails to have network, looks like DNS resolution, "dbus-org.freedesktop.resolve1.service not found"

Added by okurz 3 months ago. Updated 3 months ago.

Status:ResolvedStart date:24/06/2019
Priority:HighDue date:
Assignee:andriinikitin% Done:

0%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_from_git@64bit-2G fails in
openqa_webui

Test suite description

Maintainer: okurz@suse.de
Test for running openQA itself from git. To be used with "openqa" distri.

Reproducible

Fails since exactly Build :TW.2257 (current job) which is "openSUSE Tumbleweed 20190607 - Kernel 5.1.7-1-default"

Expected result

Last good: :TW.2252 (or more recent) which is the same Tumblweed image.

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla 3 months ago

  • Subject changed from test fails in openqa_webui - reproducibly fails to have network, looks like DNS resolution, "dbus-org.freedesktop.resolve1.service not found" to [functional][u] test fails in openqa_webui - reproducibly fails to have network, looks like DNS resolution, "dbus-org.freedesktop.resolve1.service not found"

#2 Updated by andriinikitin 3 months ago

I believe after this change https://github.com/os-autoinst/openQA/commit/1e2c7a07ec80ee7e5ddcebd4630189ed9a1a68e9#diff-420b369363778671f8801a084f065f02L24

This line must expect 127.0.0.1 instead of localhost
https://github.com/os-autoinst/os-autoinst-distri-openQA/blob/master/tests/install/openqa_webui.pm#L69 , e.g. on my local instance:

[2019-07-04T13:51:06.0366 CEST] [info] Listening at "http://127.0.0.1:9616"
[2019-07-04T13:51:06.0367 CEST] [info] Listening at "http://[::1]:9616"

#3 Updated by okurz 3 months ago

@andriinikitin ok. So you are saying that https://openqa.opensuse.org/tests/959642#step/openqa_webui/32 is just misleading?

Care to provide a PR for the tests? Using http://open.qa/docs/#_triggering_tests_based_on_an_any_remote_git_refspec_or_open_github_pull_request you can also easily test this on o3 :)

#4 Updated by okurz 3 months ago

  • Subject changed from [functional][u] test fails in openqa_webui - reproducibly fails to have network, looks like DNS resolution, "dbus-org.freedesktop.resolve1.service not found" to [tools] test fails in openqa_webui - reproducibly fails to have network, looks like DNS resolution, "dbus-org.freedesktop.resolve1.service not found"
  • Status changed from New to In Progress
  • Assignee set to andriinikitin

As you created https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/46 which I just merged I guess I can assign to you then?

Please track in production, e.g. retrigger and see if the test is fixed on o3 before closing as "Resolved". Thanks.

#5 Updated by andriinikitin 3 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF