Project

General

Profile

action #52256

[hpc][kernel] Prepare support_server NFS server

Added by sebchlad over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
QE Kernel - QE Kernel Done
Start date:
2019-05-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Some HPC tests require to use NFS server, as the 2 nodes could share one directory.

Currently I use custom test run() for this but implementing this in support_server (as there is a flag for it) would be desirable

History

#1 Updated by sebchlad over 2 years ago

tests/console/yast2_nfs_server.pm might be of help or also tests/network/autofs_server.pm

#2 Updated by sebchlad over 2 years ago

First empty PR done, just to show that I would like to use some setting to configure NFS server.

This was not really approved.

So I followed with an example and an explanation why this should be configurable.
Simplistic PR is pushed for the review.

#3 Updated by sebchlad over 2 years ago

  • Status changed from In Progress to Feedback

#4 Updated by sebchlad over 2 years ago

  • Status changed from Feedback to In Progress

#5 Updated by sebchlad over 2 years ago

  • Status changed from In Progress to Resolved

Simple implementation merged. Used with slurm tests.
Works as expected, so the issue is resolved for now.

Obvious improvements might be implemented as needed

#6 Updated by jlausuch over 2 years ago

  • Target version changed from 445 to 457

#7 Updated by pcervinka over 1 year ago

  • Target version changed from 457 to QE Kernel Done

Also available in: Atom PDF