action #51719

"New Test Suite " button in admin/test_suites can not be used with filter

Added by asmorodskyi about 1 month ago. Updated 26 days ago.

Status:ResolvedStart date:21/05/2019
Priority:NormalDue date:
Assignee:mkittler% Done:

0%

Category:Webui: General Improvements
Target version:Current Sprint
Difficulty:
Duration:

Description

  1. Define any filter in admin/test_suites
  2. Press "New Test Suite" button ==> nothing happens

Expected : empty line for new test suite should appear ( with filter reset in case there is no other way )

Note : if you will remove filter after button pressed you will get empty line for new test suite so it just simple filtered out


Related issues

Related to openQA Project - action #53402: Not possible to search for test suites (again?) using reg... New 21/06/2019
Duplicated by openQA Project - action #52385: Button 'New test suite' does not work after using table ... Rejected 31/05/2019

History

#1 Updated by mkittler about 1 month ago

  • Category set to Webui: General Improvements

Yes, it simply gets filtered out. Maybe I can prevent that somehow (1) or at least disable the button as long as filter are active (2). If I go for (1) the result might of course be filtered out when submitting. In case of (2) a hint why the button is disabled would likely be useful.

#2 Updated by asmorodskyi about 1 month ago

mkittler wrote:

Yes, it simply gets filtered out. Maybe I can prevent that somehow (1) or at least disable the button as long as filter are active (2). If I go for (1) the result might of course be filtered out when submitting. In case of (2) a hint why the button is disabled would likely be useful.

regarding filter out on submit - something similar happens currently anyway : due to pagination you are in high risk that test suite which you just created got not into first page so from user perspective it will just disappear. Not sure how it could be handled better so haven't post a ticket about that . But just mention this here to clarify that if you choose (1) you will not create some regression because this behavior exists already

#3 Updated by mkittler about 1 month ago

Yes, that's true. However, the problem that rows "disappear" after submitting due to their new position in the sort order could be solved elegantly by simply selecting the new page of the row.

Filtering is more problematic. Maybe we could simply adjust the filter in cases rows should not disappear? So creating a new test suite would clear the filter and updating a test suite would adjust the filter to include the new name as well. Than the adjusted filtering would be transparent to the user and there are also no internal hacks required.

#4 Updated by asmorodskyi about 1 month ago

mkittler wrote:

Yes, that's true. However, the problem that rows "disappear" after submitting due to their new position in the sort order could be solved elegantly by simply selecting the new page of the row.

you mean autoselecting ? yeah I like this idea ! because currently it is really confusing .

Filtering is more problematic. Maybe we could simply adjust the filter in cases rows should not disappear? So creating a new test suite would clear the filter and updating a test suite would adjust the filter to include the new name as well. Than the adjusted filtering would be transparent to the user and there are also no internal hacks required.

I would not use this way because I am afraid of plenty different scenario where such adjustment will create more problems that it solves. I would go for simple filter reset in case "New Test Suite" button was pressed. Easy to implement and pretty transparent to the user :)

#5 Updated by mkittler about 1 month ago

  • Duplicated by action #52385: Button 'New test suite' does not work after using table search. added

#6 Updated by mkittler about 1 month ago

  • Assignee set to mkittler
  • Target version set to Ready

#7 Updated by mkittler about 1 month ago

  • Status changed from New to In Progress
  • Target version changed from Ready to Current Sprint

PR for "autoselecting" of updated rows and resetting the filter before adding a new/empty row: https://github.com/os-autoinst/openQA/pull/2089

#8 Updated by okurz 26 days ago

  • Status changed from In Progress to Resolved

PR merged, live on https://openqa.opensuse.org/admin/test_suites and working as expected with proper focussing as well as filter resetting

#9 Updated by okurz 25 days ago

  • Related to action #53402: Not possible to search for test suites (again?) using regex, e.g. `^gnome$` added

Also available in: Atom PDF