Project

General

Profile

action #50810

[functional][y][sporadic][timeboxed:6h] test fails in yast2_lan - a network bridge interface created?

Added by mlin7442 over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Spike/Research
Target version:
SUSE QA - Milestone 25
Start date:
2019-04-26
Due date:
2019-06-18
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

A network bridge interface appeared sporadically. Causing the needle to fail.

Acceptance criteria

  • AC: The reason why the bridge interface appeared is known.

Exit criteria

  • EC: The issue is not reproducible anymore.

Reproducible

Fails sporadically since Build 20190425
in scenario opensuse-Tumbleweed-NET-x86_64-cryptlvm@64bit

Expected result

Last good: 20190505

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla over 3 years ago

  • Subject changed from test fails in yast2_lan - a network bridge interface created? to [functional][y][sporadic] test fails in yast2_lan - a network bridge interface created?
  • Description updated (diff)
  • Category changed from Bugs in existing tests to Spike/Research

#2 Updated by riafarov about 3 years ago

  • Subject changed from [functional][y][sporadic] test fails in yast2_lan - a network bridge interface created? to [functional][y][sporadic][timeboxed:6h] test fails in yast2_lan - a network bridge interface created?
  • Due date set to 2019-06-18
  • Status changed from New to Workable

#3 Updated by riafarov about 3 years ago

  • Priority changed from Normal to High
  • Target version set to Milestone 26

We should take a look before logs get rotten.

#5 Updated by riafarov about 3 years ago

  • Target version changed from Milestone 26 to Milestone 25

#6 Updated by JERiveraMoya about 3 years ago

I noticed in the logs one difference related with the use of the previous firewall tool, although I'm not sure if relevant enough.
Failing one in https://openqa.opensuse.org/tests/918797/file/serial0.txt

sysconfig [0.85.2-1.1.x86_64] < SuSEfirewall2
sysconfig-netconfig [0.85.2-1.1.x86_64] < wicked < wicked-service < sysconfig < SuSEfirewall2

Passing one in https://openqa.opensuse.org/tests/953524/file/serial0.txt:

sysconfig [0.85.2-1.2.x86_64] < yast2
sysconfig-netconfig [0.85.2-1.2.x86_64] < wicked < wicked-service < sysconfig < yast

#7 Updated by JERiveraMoya about 3 years ago

  • Assignee set to JERiveraMoya

#8 Updated by JERiveraMoya about 3 years ago

  • Status changed from Workable to In Progress

#9 Updated by JERiveraMoya about 3 years ago

According to yast developers it is strange that the dep appears sometimes but not related with this issue.
YaST logs are rotated much earlier than when it is failing in openQA so I'm running some statistics in local with custom yaml schedule: 50 round

#10 Updated by JERiveraMoya about 3 years ago

It couldn't be caught in my local.
Trying another 50 round but this time in O3.

#11 Updated by JERiveraMoya about 3 years ago

3 out of 50 show the problem. Checking with YaST developers:
https://openqa.opensuse.org/tests/956423#step/check_network/10
https://openqa.opensuse.org/tests/956462#step/check_network/10
https://openqa.opensuse.org/tests/956468#step/check_network/10

Another 50 round in O3 but this time not setting Y2DEBUG as the logs are still rotated.

#12 Updated by JERiveraMoya about 3 years ago

1 out of 50 failed creating br0.

#13 Updated by JERiveraMoya about 3 years ago

  • Status changed from In Progress to Resolved

Created bug: https://bugzilla.suse.com/show_bug.cgi?id=1137992
Most possible culprit/contributor to the sporadic failure is that xen virtualization tools are installed and yast trigger condition to create that bridge, but we will have to wait resolution of the bug to know why as same tools are installed in scenarios that pass. At least now we are closer and we have logs and statistics.

#14 Updated by JERiveraMoya about 3 years ago

  • Status changed from Resolved to In Progress

Re-opening to try another suggestion in the bug about to know which package provides xen in the installed system:
50 runs
btw, I'm using this PR to create the runs.

#16 Updated by JERiveraMoya about 3 years ago

  • Status changed from In Progress to Resolved

Patch submitted to OBS, see comment. Closing the investigation.

#17 Updated by JERiveraMoya about 3 years ago

  • Status changed from Resolved to In Progress

I was trying a couple of thing today:

  • Staging J contains the changes but I couldn't find a mirror for NET installation, what I guess it makes sense because builds are triggered very frecuenty.
  • Now I'm going to try to ignore the issues with broken packages that DUD produces to finish the installation: 50 runs

#18 Updated by JERiveraMoya about 3 years ago

It was caught: https://openqa.opensuse.org/tests/961598#step/check_network/16 so developer can move forward.

#19 Updated by JERiveraMoya about 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF