Project

General

Profile

action #50066

[functional][y] select_console fails to log-in as root

Added by JRivrain over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Spike/Research
Target version:
SUSE QA - Milestone 24
Start date:
2019-04-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

It looks like the password has been either not set or set to an unexpected value.
The test failed at that step for the two last builds. I tried to login with VNC and enter the password, it also failed... so it is not a latency/race condition issue.
I am not sure if this is a product bug or an issue on our side, so I make this ticket as spike/research.

The password in the autoyast seems correct:
$6$OwCxlrlp4ZEd$Y1qYr1UBMLb4GCiJNfOUM42WR4GkHq69SYQpk9oMmtM0JrXEFgXO68yuiiBM4MGblmgUmwD9dYubjZQx.t3JZ/

corresponds to the expected:

root@/home/jonathan # mkpasswd --method=sha-512 --salt=OwCxlrlp4ZEd
Password: 
$6$OwCxlrlp4ZEd$Y1qYr1UBMLb4GCiJNfOUM42WR4GkHq69SYQpk9oMmtM0JrXEFgXO68yuiiBM4MGblmgUmwD9dYubjZQx.t3JZ/

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-autoyast_reinstall@64bit fails in
console

Test suite description

Parent job produces autoyast profile after successful completion. This test uses generated profile to do autoyast installation.

Reproducible

Fails since (at least) Build 24.5

Expected result

Last good: 22.15 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #50399: [functional][y] Installer doesn't react to key pressClosed2019-04-15

History

#1 Updated by riafarov over 2 years ago

  • Assignee set to riafarov
  • Target version set to Milestone 24

So, I've taken a closer look and system has serious performance issues, so keys are lost when I try to log in. After some time it works fine. Let's wait for https://bugzilla.suse.com/show_bug.cgi?id=1130158 being fixed first as might be related.

#2 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: autoyast_reinstall
https://openqa.suse.de/tests/2805042

#3 Updated by riafarov over 2 years ago

  • Status changed from New to Blocked

#4 Updated by riafarov over 2 years ago

  • Related to action #50399: [functional][y] Installer doesn't react to key press added

#5 Updated by riafarov over 2 years ago

  • Status changed from Blocked to Rejected

Let's reject that one as it's qemu issue. I will try to find the way how we can proceed.

Also available in: Atom PDF