action #49520

[functional][u] Add an extra unique worker class to each worker host

Added by SLindoMansilla 11 months ago. Updated 10 months ago.

Status:RejectedStart date:20/03/2019
Priority:HighDue date:
Assignee:szarate% Done:

0%

Category:Infrastructure
Target version:QA - future
Difficulty:easy
Duration:

Description

Motivation

Sometimes a bug happens in a specific worker host. When trying to debug, we don't have a way of specifying in a job, which worker host to pick.
It would be useful for debugging to have a unique worker class name, so that a job can be set up to pick a worker instance from a specific worker host.

Suggestions

https://gitlab.suse.de/openqa/salt-states-openqa/blob/master/openqa/workers.ini:

Example output:
```
openqaworker13:
# 16 cores
...
global:
WORKER_CLASS: openqaworker13,qemu_amd64,qemu_x86_64_staging

malbec:
numofworkers: 4
...
global:
QEMUTHREADS: 1
WORKER_CLASS: malbec,qemu_ppc64le,qemu_ppc64le_no_tmpfs,tap
```

Acceptance criteria

  • AC1: A job can be set up to be picked by a specific worker host.
  • AC2: Worker hostname is added as worker class automatically by salt.

Related issues

Related to openQA Tests - action #48635: [functional][u] test fails in kvm - no svm flag for openq... Resolved 04/03/2019

History

#1 Updated by SLindoMansilla 11 months ago

  • Related to action #48635: [functional][u] test fails in kvm - no svm flag for openqaworker13 (AMD worker) added

#2 Updated by SLindoMansilla 11 months ago

  • Description updated (diff)

This could unblock the high prio ticket: #48635

#3 Updated by SLindoMansilla 11 months ago

  • Description updated (diff)

#4 Updated by SLindoMansilla 11 months ago

  • Priority changed from Urgent to High

#5 Updated by SLindoMansilla 11 months ago

  • Assignee set to szarate

Assigning to you as a reminder.

As spoken, could you check if this is a duplicate of an already existing ticket?

#6 Updated by SLindoMansilla 11 months ago

  • Description updated (diff)
  • Status changed from New to Workable

#8 Updated by szarate 10 months ago

Sergio, looks like I did find the ticket :)

#10 Updated by SLindoMansilla 10 months ago

  • Status changed from Workable to Rejected

As duplicate of #27811

#11 Updated by SLindoMansilla 10 months ago

  • Related to deleted (action #48635: [functional][u] test fails in kvm - no svm flag for openqaworker13 (AMD worker))

#13 Updated by SLindoMansilla 10 months ago

  • Related to action #48635: [functional][u] test fails in kvm - no svm flag for openqaworker13 (AMD worker) added

Also available in: Atom PDF