action #48482

[ipmi][functional][u] test fails in reboot_after_installation; The console isn't responding correctly. Maybe half-open socket

Added by michalnowak 11 months ago. Updated 11 months ago.

Status:ResolvedStart date:27/02/2019
Priority:HighDue date:
Assignee:okurz% Done:

0%

Category:Bugs in existing tests
Target version:SUSE QA tests - Milestone 23
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-gi-guest_sles11sp4-on-host-developing-kvm@64bit-ipmi fails in
reboot_after_installation

From the log: "The console isn't responding correctly. Maybe half-open socket? at /usr/lib/os-autoinst/backend/baseclass.pm line 245."

There were changes in the restart handling code: https://github.com/os-autoinst/os-autoinst-distri-opensuse/commits/master/lib/power_action_utils.pm.

Test suite description

Reproducible

Fails since (at least) Build 178.1

Expected result

Last good: 177.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #32746: [sle][tools][remote-backends][hard] Incomplete job becaus... Resolved 05/03/2018

History

#1 Updated by cachen 11 months ago

Please follow https://progress.opensuse.org/issues/32746#change-193802

the error hitting had been reduced in virtualization tests by the merged PR#5915, it looks to me the failure happens again cause by the rewrite in commit 023c4c09dca87d17b3cec325f3adb5288525a211 :)

#2 Updated by cachen 11 months ago

  • Related to action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMI added

#3 Updated by xlai 11 months ago

  • Assignee set to michalnowak

Actually after PR#5915 merged, I rarely see the 'half-open socket' issue. From code view, the change by commit 023c4c09dca87d17b3cec325f3adb5288525a211 is likely to retrigger the issue.

@michal, would you please help to limit the change in your above commit only to non-ipmi?

#4 Updated by okurz 11 months ago

@michalnowak I prepared a revert of your PR for discussion: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6919

Please see a14a5c550 from me which deleted the wait_screen_change to improve stability on ipmi in ticket #32746

#5 Updated by michalnowak 11 months ago

Thanks for the explanation @okurz, makes sense not to trigger wait_screen_change in this situation.

#6 Updated by okurz 11 months ago

  • Subject changed from [ipmi] test fails in reboot_after_installation; The console isn't responding correctly. Maybe half-open socket to [ipmi][functional][u] test fails in reboot_after_installation; The console isn't responding correctly. Maybe half-open socket
  • Status changed from New to Feedback
  • Assignee changed from michalnowak to okurz
  • Priority changed from Normal to High
  • Target version set to Milestone 23

Updated my PR according to your comments.

#7 Updated by okurz 11 months ago

  • Status changed from Feedback to Resolved

Merged. This should bring us back to the old state.

Also available in: Atom PDF