Project

General

Profile

action #48176

action #40475: [functional][y][saga] Establish YaST team split

action #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job group

[sle][functional][y] implement validation for autoyast_gnome test suite

Added by riafarov over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
SUSE QA tests - Milestone 23
Start date:
2018-10-25
Due date:
2019-03-26
% Done:

0%

Estimated time:
5.00 h
Difficulty:
Duration: 109

Description

See motivation in the parent ticket.

We have autoyast_gnome which runs standard set of test modules, which is overkill, considering that we execute same set already for same installation.
We need to limit scope there, not to execute duplicate tests, but still validate SUT.
Examples of relevant checks: list of repositories, partitioning, packages installed as per profile, systemd target.

Acceptance criteria

  1. Only relevant test modules are scheduled for autoyast_gnome scenario for SLE and openSUSE

Suggestions

  1. Identify difference to default test suite in Functional job group and cover those
  2. Add some smoke test checks for the installation

History

#1 Updated by riafarov over 1 year ago

  • Copied from action #48173: [sle][functional][y] implement validation for encrypt lvm test suites added

#2 Updated by riafarov over 1 year ago

  • Copied from deleted (action #48173: [sle][functional][y] implement validation for encrypt lvm test suites)

#3 Updated by riafarov over 1 year ago

  • Parent task set to #42941

#4 Updated by riafarov over 1 year ago

  • Parent task deleted (#42941)

#5 Updated by riafarov over 1 year ago

  • Parent task set to #42494

#6 Updated by ybonatakis over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to ybonatakis

#7 Updated by riafarov over 1 year ago

  • Description updated (diff)

#8 Updated by riafarov over 1 year ago

  • Estimated time set to 5.00 h

#9 Updated by ybonatakis over 1 year ago

  • Status changed from In Progress to Feedback

#10 Updated by riafarov over 1 year ago

  • Due date changed from 2019-03-12 to 2019-03-26

#11 Updated by JERiveraMoya over 1 year ago

  • Status changed from Feedback to In Progress

ybonatakis I triggered the verification run for sle15sp1 this morning and now it is running: https://openqa.suse.de/tests/2706459
Previous runs from yesterday showed error on tests/console/autoyast_smoke.pm: Can't locate (perhaps some misconfiguration that is already fixed?)
In O3 for TW INSTALLATION_VALIDATION=console/autoyast_smoke was not set yesterday so I retrigger it setting it and the test suite looks fine now: https://openqa.opensuse.org/tests/888159

#12 Updated by JERiveraMoya over 1 year ago

  • Status changed from In Progress to Resolved

Both passed, let's resolve it.

Also available in: Atom PDF