Project

General

Profile

action #47924

[qam][functional][y][fast] wrong patterns in installation_overview on SLE 15

Added by bfilho over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 23
Start date:
2019-02-14
Due date:
2019-02-26
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Server-DVD-Updates-x86_64-create_hdd_minimal_base+sdk@64bit fails in
installation_overview

Test suite description

Use ftp instead of ISO, see poo#20984.
Contact person: riafarov@suse.com or riafarov in irc.
Settings backup: ADDONS=sdk ISO_1=SLE-%VERSION%-SDK-DVD-%ARCH%-Build%BUILD_SDK%-Media1.iso
Remove ADDONURL and ADDONURL_SDK

For SLE15 we don't have SDK, as workaround we add all addons as SCC cannot currently be used : bsc#1054375 and other. WORKAROUND_MODULES setting activates this behavior, doesn't affect any other versions of SLE.

Reproducible

Fails since (at least) Build 20190213-1 (current job)

Expected result

Last good: 20190214-1 (or more recent)

Further details

Selected patterns seems to be wrong: "patterns: base system" instead of the expected "base system and enhanced base system" (as seen on https://openqa.suse.de/tests/2443010#step/installation_overview/1).
This is causing many issue into the Test Repo SLE 15 on qam tests: https://openqa.suse.de/tests/overview?distri=sle&version=15&build=20190213-1&groupid=165 and on

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #46682: [functional][y] lvm test need more than 2 hours to run - optimize select_patterns_and_packagesResolved2019-01-252019-02-26

History

#1 Updated by bfilho over 2 years ago

  • Related to action #46682: [functional][y] lvm test need more than 2 hours to run - optimize select_patterns_and_packages added

#2 Updated by coolo over 2 years ago

  • Priority changed from Normal to Urgent

Setting this to urgent on behalf of Marcus

#3 Updated by JERiveraMoya over 2 years ago

It is trying to unselect enhanced basesystem because it has been already processed (with the new changes in PR-6732 due to it is matching 100% for both basesystem and enhance basesystem. I'm going to try to create individual needles.

#5 Updated by okurz over 2 years ago

  • Subject changed from [qam] wrong patterns in installation_overview on SLE 15 to [qam][functional][y][fast] wrong patterns in installation_overview on SLE 15
  • Due date set to 2019-02-26
  • Status changed from New to Resolved
  • Assignee set to JERiveraMoya
  • Target version set to Milestone 23

Seems like you fixed it then? https://openqa.suse.de/tests/2465959

Also available in: Atom PDF