Project

General

Profile

action #46577

[sle][migration][sle15sp1]test fails in grub_test_snapshot - grub not show after reboot

Added by coolgw over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-01-24
Due date:
% Done:

100%

Estimated time:
40.00 h
Difficulty:

Description

Observation

openQA test in scenario OpenQA::Schema::Result::TestSuites=HASH(0xa00d558) fails in
grub_test_snapshot

Reproducible

Fails since (at least) Build 144.3 (current job)

Expected result

Last good: 125.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 3 years ago

We can see that the plymouth boot splash is still active and the balls are running left and right :) The generic post-fail-hook from https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/opensusebasetest.pm#L628 seems to trigger the detection of blocked tasks where there are none but probably https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/opensusebasetest.pm#L645 is never reached because the variable "in_boot_desktop" is not set. I recommend to look into how the variable should be set when a boot is requested from grub_test_snapshot so that a more helpful post_fail_hook content is executed, for example also https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/opensusebasetest.pm#L650 should help if it would be called.

#2 Updated by coolgw over 3 years ago

  • Assignee set to coolgw

#3 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_scc_base_all_full
https://openqa.suse.de/tests/2396588

#4 Updated by coolgw over 3 years ago

latest result show can not reach grub_test_snapshot.
https://openqa.suse.de/tests/2448879

#5 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp4_pscc_sdk_def_full
https://openqa.suse.de/tests/2511585

#6 Updated by leli over 3 years ago

  • Estimated time set to 80.00 h

#7 Updated by tinawang123 over 3 years ago

  • Assignee changed from coolgw to tinawang123

#8 Updated by maritawerner over 3 years ago

Any update here? This blocking quite some testcases and we need to have everything in shape soon. We are approaching RC2.

#9 Updated by leli over 3 years ago

  • Priority changed from Normal to High
  • Estimated time changed from 80.00 h to 40.00 h

#10 Updated by tinawang123 over 3 years ago

  • Status changed from New to Rejected

I checked video, it cannot show grub, it has the same problem with grub_test module
All of them blocked by bsc#1129504

#11 Updated by maritawerner over 3 years ago

Ok, can we add a softfail to those testcases? We are almost at RC2 and we need a clear product status in openQA?

#12 Updated by tinawang123 over 3 years ago

  • Status changed from Rejected to In Progress

I think we can do soft fail at here.
But I didn't have worker to test this.
Our ppc64le worker cannot be used now.

#13 Updated by leli over 3 years ago

  • Assignee changed from tinawang123 to leli

#14 Updated by leli over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

We have done a workaround for this issue PR# https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7196. With this workaround we can see there is no such issue happened on build 205.1.

#15 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_rmt_sdk_all_full
https://openqa.suse.de/tests/2741519

Also available in: Atom PDF