Project

General

Profile

action #46433

[sle][migration][sle15sp1]test fails in keymap_or_locale - xterm not start

Added by coolgw almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-01-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-aarch64-offline_sles12sp3_media_tcm_all_full@aarch64 fails in
keymap_or_locale

Reproducible

Fails since (at least) Build 104.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #46532: [functional][u] test fails in keymap_or_locale as the test fails to unlock the screenlock when it should not even care about the displaymanagerResolved2019-01-23

History

#1 Updated by leli almost 4 years ago

  • Assignee set to leli

#2 Updated by leli almost 4 years ago

  • Status changed from New to Rejected

Run it several times on o.s.d. but can't reproduced. I think it should be worker performance issue which cause the xterm not be lauched in time.
https://openqa.suse.de/tests/2394038

Reject it.

#3 Updated by okurz almost 4 years ago

  • Status changed from Rejected to New

Hi leli, sorry for reopening the ticket. I just want to ensure that we can improve our overall system reliability. IMHO "worker performance" should not be a reason to accept the current state as is. I see the following options. Either you investigate further in the direction of "worker performance" and see if this is something tangible which in the end would also demand a fix. Or maybe the test actually can be made more stable. Regarding the latter just yesterday I realized that the test module "keymap_or_locale" within the x11 tests should only be triggered way later after we ensured that e.g. xterm can be started. See #46532.

So could you please take a look into your hypothesis of "worker performance" or propose changes to the test code? If you think I am wrong feel free to close the ticket again accordingly. I hope for your understanding.

#4 Updated by okurz almost 4 years ago

  • Related to action #46532: [functional][u] test fails in keymap_or_locale as the test fails to unlock the screenlock when it should not even care about the displaymanager added

#5 Updated by leli almost 4 years ago

Hi Oliver, I agree you opinion, we should to make the test more stable. While I have checked migration job group, there is only one job with this issue, re-run several times and can't reproduce. In fact, there is a default policy in our team, if a job fail and can't reproduce by re-run, we won't file a ticket. Anyway, currently I just suggest to reject it and keep an eye on this issue. WDYT?

#6 Updated by okurz almost 4 years ago

  • Status changed from New to Rejected

Yes, of course. Your policy makes sense. I just wanted to clarify. However, we still have #46532 to improve what we already know about keymap_or_locale. Setting to original state.

Also available in: Atom PDF