Project

General

Profile

Actions

action #45731

closed

Bug: firewalld is blocking everything until it's restarted

Added by flacco over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2019-01-04
Due date:
2019-08-31
% Done:

100%

Estimated time:

Description

After a reboot of an invis server the new firwalld daemon is blocking everything until it is restarted.

Actions #1

Updated by flacco over 5 years ago

  • Related to action #36079: Modify sine2 / invisAD-setup to be compatible with leap 15 added
Actions #2

Updated by flacco over 5 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 80

It seems that firewalld starts to early. The original service-unit file defines to start firewalld before "network-pre.target":

"[Unit]
Description=firewalld - dynamic firewall daemon
Before=network-pre.target
Wants=network-pre.target
After=dbus.service
After=polkit.service
..."

Starting firewalld later brings the risk that the system runs for a few moments without the firewall. Sytemd knows three different network targets. "network-pre.target", "network.target" and "network-online.target". The last one means that all network interfaces are up and online. Starting the firewall before this target should be secure enough.

Changing the firewalld service-unit file to:

"[Unit]
Description=firewalld - dynamic firewall daemon
After=network-pre.target
Before=network-online.target
After=dbus.service
After=polkit.service
..."

did the job. This should be secure enough.

Actions #3

Updated by flacco over 5 years ago

... but I don't know if we should place a "Wants=network.online.target" in the service-unit file?

Actions #4

Updated by ingogoeppert over 5 years ago

firewalld does not start to early. It works on my system. I am unable to reproduce this issue.

Actions #5

Updated by flacco over 5 years ago

  • Target version changed from 14.0 to Future
Actions #6

Updated by flacco over 5 years ago

  • Related to deleted (action #36079: Modify sine2 / invisAD-setup to be compatible with leap 15)
Actions #7

Updated by flacco over 5 years ago

  • Target version changed from Future to 14.1
Actions #8

Updated by flacco over 5 years ago

  • Due date changed from 2019-01-11 to 2019-02-28
Actions #9

Updated by ingogoeppert almost 5 years ago

  • Target version changed from 14.1 to 14.2
Actions #10

Updated by ingogoeppert almost 5 years ago

  • Due date changed from 2019-02-28 to 2019-08-31
Actions #11

Updated by ingogoeppert about 4 years ago

  • Status changed from In Progress to Workable
Actions #12

Updated by ingogoeppert about 4 years ago

  • Status changed from Workable to Closed
Actions #13

Updated by ingogoeppert over 2 years ago

  • % Done changed from 80 to 100
Actions

Also available in: Atom PDF