tickets #44903

New Mirror in India

Added by rahulmkhj@gmail.com 6 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:pjessen% Done:

100%

Category:mirrors
Target version:-
Duration:

Description

Dear Admin,

We've just setup a new mirror in India, and would like it to be listed for
public use with following details:

Thank you.
Rahul

History

#1 Updated by cboltz 6 months ago

  • Category set to mirrors
  • Assignee set to pjessen

#2 Updated by pjessen 6 months ago

  • Status changed from New to Feedback
  • Private changed from Yes to No

Hi Rahul

thanks for volunteering your time and resources to join the openSUSE mirror infrastructure, much appreciated!

A couple of things - you don't have an email address directly with Esto Internet?

I see no reverse mappings for your server addresses -


# host opensuse.mirrors.estointernet.in
opensuse.mirrors.estointernet.in has address 103.97.46.254
opensuse.mirrors.estointernet.in has IPv6 address 2001:df4:a300:1::ffff
# host 103.97.46.254
;; connection timed out; no servers could be reached
# host 2001:df4:a300:1::ffff
Host f.f.f.f.0.0.0.0.0.0.0.0.0.0.0.0.1.0.0.0.0.0.3.a.4.f.d.0.1.0.0.2.ip6.arpa not found: 3(NXDOMAIN)

It is not critical, but makes admin much easier if we can just add your server by name instead of having to add the addresses. If you can fix the reverse mapping, that would be great.

#3 Updated by rahulmkhj@gmail.com 6 months ago

Hi.

Yes I do have an email address @estointernet.in. But, since all other
mirrors ubuntu/centos/apache etc are linked to this email address, I prefer
all mirrors under the same email address.

And for reverse lookup, to be frank we're not hosting our own DNS Servers
and I've failed in my past attempts of adding reverse DNS entries with
public DNS server i.e. google domains or cloudflare. I can give it another
try if you can share some "how to" on that.

Thank you.
Rahul

#4 Updated by pjessen 6 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

rahulmkhj@gmail.com wrote:

Hi.


Yes I do have an email address @estointernet.in. But, since all other

mirrors ubuntu/centos/apache etc are linked to this email address, I prefer

all mirrors under the same email address.

Okay, it's not a problem. Usually mirrors use a common address, such as e.g. mirror@, that means change of staff does not impact mirror operation.

And for reverse lookup, to be frank we're not hosting our own DNS Servers

and I've failed in my past attempts of adding reverse DNS entries with

public DNS server i.e. google domains or cloudflare. I can give it another

try if you can share some "how to" on that.

Here's what I have done in the past -

a) ask my provider to delegate the reverse zone to our own DNS
b) ask my provider to update their reverse zones (send an email).

I have updated the stage.o.o acl and added your mirror, it should be active:


# mb show esto
identifier : mirror.estointernet.in
operatorName : Esto Internet
operatorUrl : https://estointernet.in
baseurl : http://opensuse.mirrors.estointernet.in
baseurlFtp :
baseurlRsync : rsync://opensuse.mirrors.estointernet.in/opensuse
region : as
country : in
asn : 0
prefix : 0.0.0.0/0
lat,lng : 20.000,77.000
regionOnly : False
countryOnly : True
asOnly : False
prefixOnly : False
ipv6Only : False
otherCountries :
fileMaxsize : 0
publicNotes :
score : 100
enabled : False
statusBaseurl : False
admin : Rahul
adminEmail : rahulmkhj@gmail.com

# mb scan -e mirror.estointernet.in
Mon Dec 10 10:30:20 2018 mirror.estointernet.in: starting
Mon Dec 10 10:30:24 2018 mirror.estointernet.in: total files before scan: 0
Mon Dec 10 10:31:41 2018 mirror.estointernet.in: scanned 84985 files (1097/s) in 77s
Mon Dec 10 10:31:41 2018 mirror.estointernet.in: files to be purged: 0
Mon Dec 10 10:31:44 2018 mirror.estointernet.in: total files after scan: 84985 (delta: 84985)
Mon Dec 10 10:31:44 2018 mirror.estointernet.in: purged old files in 3s.
Mon Dec 10 10:31:44 2018 mirror.estointernet.in: now enabled.
Mon Dec 10 10:31:44 2018 mirror.estointernet.in: done.
Mon Dec 10 10:31:44 2018 mirror.estointernet.in: testing status of base URL...
Mon Dec 10 10:31:44 2018 mirror.estointernet.in: OK. Mirror is online now.
Completed in 1.4 minutes

#5 Updated by tampakrap 6 months ago

  • Private changed from No to Yes

@Per, I disabled the mirror because it had prefix 0.0.0.0/0 which was causing frequent crashes to mirrorbrain. Maybe the URL is wrong and it should be opensuse.mirror.estointernet.in?

#6 Updated by tampakrap 6 months ago

  • Status changed from Closed to New

#7 Updated by pjessen 6 months ago

Weird.

The URL is correct -

# host opensuse.mirrors.estointernet.in
opensuse.mirrors.estointernet.in has address 103.97.46.254
opensuse.mirrors.estointernet.in has IPv6 address 2001:df4:a300:1::ffff
# host opensuse.mirror.estointernet.in
Host opensuse.mirror.estointernet.in not found: 3(NXDOMAIN)

# mb iplookup 103.97.46.254
0.0.0.0/0 (AS0) None

The correct answer is prefix = 103.97.46.0/24, asn 135817

Hmm, I have seen this one before, I think it happened for my own mirror too. It shouldn't cause a crash though.
IIRC, it is our information that is incomplete. I can't remember how to get it updated.

#8 Updated by pjessen 6 months ago

I'm going to try a manual update for now - I think the issue is that we are not getting our route data updated, due to this script failure:

Downloading http://mirrorbrain.org/routeviews/oix-full-snapshot-latest.dat.bz2
Traceback (most recent call last):
File "/usr/bin/asn_import", line 23, in
config = mb.conf.Config(instance = mirrorbrain_instance)
File "/usr/lib64/python2.7/site-packages/mb/conf.py", line 58, in init
% self.instance)
KeyError: "Config error: 'main' is not listed in instances"

See https://progress.opensuse.org/issues/37099

#9 Updated by pjessen 6 months ago

  • Status changed from New to In Progress

I think I have fixed the route views update problem, but it did not help:

# mb update -a mirror.estointernet.in
mirror.estointernet.in: STRANGE! There's no ASN containing this hosts IP address (103.97.46.254)...
# mb update -p mirror.estointernet.in
mirror.estointernet.in: updating network prefix (103.97.46.0/24 -> 0.0.0.0/0)

#10 Updated by pjessen 6 months ago

The pfx2asn table on mirrordb1 does in fact not have an entry for 103.97.46.254.
This data is provided externally from
http://mirrorbrain.org/routeviews/oix-full-snapshot-latest.dat.bz2


select * from pfx2asn where pfx::char(32) like '103.97%';
pfx | asn
-----------------+-------
103.97.47.0/24 | 45804
103.97.48.0/23 | 38090
103.97.48.0/24 | 38090
103.97.49.0/24 | 38090
103.97.53.0/24 | 63956
103.97.84.0/24 | 45804
103.97.111.0/24 | 58820
103.97.134.0/24 | 31972
103.97.135.0/24 | 31972
103.97.140.0/23 | 58820
103.97.140.0/24 | 58820
103.97.141.0/24 | 58820
103.97.154.0/24 | 58893
103.97.168.0/24 | 58893
103.97.169.0/24 | 58893
103.97.174.0/24 | 56305
103.97.176.0/24 | 58879
103.97.177.0/24 | 58879
103.97.178.0/24 | 58879
103.97.179.0/24 | 58879
103.97.180.0/24 | 45194
103.97.224.0/22 | 21859
103.97.231.0/24 | 9498
103.97.232.0/22 | 4686
103.97.236.0/22 | 4686
103.97.249.0/24 | 18196
(26 rows)

#11 Updated by rahulmkhj@gmail.com 6 months ago

Hi,

I don't know if I'm supposed to intervene. But as per the db search
103.97.47.0/24 is associated with 45804 (Meghbela). While in-fact, both of
these prefixes i.e. 103.97.46.0/24 and 103.97.47.0/24 are originating from
same AS 135817 (Esto Broadband).

Thank you.
Rahul

#12 Updated by pjessen 6 months ago

Okay, have identified the problem.

The ASN for 103.97.46.254 is 135817, which is being ignored by asn_import, max accepted ASN is 65535. (16bit number).
I'm not an expert on this, but afaiu, ASN numbers have been expanded to 4bytes. The mirrorbrain database field is an integer, so it ought to have room.
Looking at the oix snapshot, there is plenty of 32bit ASNs in use.

#13 Updated by pjessen 6 months ago

Judging by the source for mod_asn, the next version (1.7) would solve this problem, by permitting 32bit ASNs. Doesn't look like we have 1.7 ready anywhere (42.3, 15.0, TW).

#14 Updated by rahulmkhj@gmail.com 6 months ago

do we have a temporary fix for this or the mirror cannot go live until 1.7?

#15 Updated by pjessen 6 months ago

  • Private changed from Yes to No

rahulmkhj@gmail.com wrote:

do we have a temporary fix for this or the mirror cannot go live until 1.7?

I have updated the mirror specs manually, your mirror has been live since 18 December.
What we need, but not urgently, is an update of mod_asn to version 1.7.

#16 Updated by pjessen 5 months ago

  • Status changed from In Progress to Closed

I'm closing this, any update of mod_asn will have to be tracked elsewhere.

Also available in: Atom PDF