Project

General

Profile

action #44453

[sle][qam] test fails in ant - new test never worked on SLES

Added by zluo almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-11-28
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

I think this new test module has not been tested for SLES 15 SP1.

I see No provider of 'ant' found for zypper install

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-extra_tests_in_textmode@svirt-xen-pv fails in
ant

Reproducible

Fails since (at least) Build 101.2 (current job)

Expected result

Last good: 100.4 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #44306: [qam] test fails in ant due to com.sun.tools.javac.Main not being on the classpathClosed2018-11-23

History

#1 Updated by zluo almost 3 years ago

  • Priority changed from Normal to High

this test module is blocking further tests, so set it as high.

#2 Updated by okurz almost 3 years ago

  • Subject changed from [sle][functional[[u] test fails in ant - new test never worked on SLES to [sle][qam] test fails in ant - new test never worked on SLES
  • Assignee set to geor
  • Priority changed from High to Urgent

geor, are you "George Gkioulis ggkioulis@suse.com"? Can you please take a look into this issue urgently?

#3 Updated by geor almost 3 years ago

  • % Done changed from 0 to 90

#4 Updated by geor almost 3 years ago

okurz wrote:

geor, are you "George Gkioulis ggkioulis@suse.com"? Can you please take a look into this issue urgently?

Hi! That's me! The ant package requires sle-module-development-tools so it should be run in the relevant setup. Should I alert someone to schedule it differently?

#5 Updated by okurz almost 3 years ago

Well, the common practice is that you fix it as you introduced the code change. This should all be controllable by code changes in os-autoinst-distri-opensuse, probably the fastest solution is to revert your initial PR to give you time to recreate one in a slightly different way. There are also other test modules that enable that call add_suseconnect_product from lib/registration, maybe look into them as an example?

#7 Updated by geor almost 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 90 to 100

Ok, so I will not test this package for that sle version. I modified the test.

#8 Updated by geor almost 3 years ago

okurz, could you please merge the pull request that resolves the issue?

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6314

#11 Updated by okurz almost 3 years ago

  • Related to action #44306: [qam] test fails in ant due to com.sun.tools.javac.Main not being on the classpath added

#12 Updated by okurz almost 3 years ago

PR was merged, thank you. After we verified that this actually fixes the failures we can reduce the priority but I suggest to keep this ticket open until we made the test module work on other products as well, ok?

#13 Updated by geor almost 3 years ago

okurz wrote:

PR was merged, thank you. After we verified that this actually fixes the failures we can reduce the priority but I suggest to keep this ticket open until we made the test module work on other products as well, ok?

Sure!

#14 Updated by geor almost 3 years ago

Should the ticket be closed now?

#15 Updated by geor over 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF