Project

General

Profile

action #43973

WebUI produces invalid links for builds with multiple distris

Added by RBrownSUSE over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2018-11-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

As of the deployment of Version 4.6.1542530127.60004e2a, openqa.opensuse.org no longer has a webui that produces links that show Kubic results

Clicking on the link to a build (eg Build20181116) on the frontpage takes you to a link with URL:

https://openqa.opensuse.org/tests/overview?distri=kubic&distri=opensuse&version=Tumbleweed&build=20181116&groupid=1

The resulting results list is missing any and all Kubic results, despite Kubic being a key part of that job group.

As a workaround, you can use https://openqa.opensuse.org/tests/overview?build=20181116&groupid=1

But without a fix it means that regular users it is now impossible to see or review the results for Kubic

History

#1 Updated by coolo over 1 year ago

  • Target version set to Current Sprint

this looks like a regression of PR 1852

#2 Updated by mkittler over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to mkittler

#3 Updated by mkittler over 1 year ago

Yes, likely a regression of PR 1852. Although I'm not really sure what broke it exactly as it looks like it would never have worked before. I removed that 'magic pass every query parameter directly to DBIx' line: %search_args = (%search_args, %{$controller->req->params->to_hash}); because it looked a bit dangerous.

I updated my PR for fixes regarding the filter: https://github.com/os-autoinst/openQA/pull/1871

If multiple distri/version/flavor/build params are provided, those are now combined with logical or. I assume that's what we want and what the filter did before.

#4 Updated by mkittler over 1 year ago

  • Status changed from In Progress to Resolved

PR is merged

Also available in: Atom PDF