action #43031

Fix failing t/ui/13-admin.t

Added by mkittler over 1 year ago. Updated over 1 year ago.

Status:ResolvedStart date:29/10/2018
Priority:NormalDue date:
Assignee:mkittler% Done:

0%

Category:-
Target version:Done
Difficulty:
Duration:

Description

Seems like t/ui/13-admin.t fails now quite often on Travis:

    #   Failed test 'advanced_kde not selectable twice'
    #   at ./t/ui/13-admin.t line 416.
    #     Structures begin differing at:
    #          $got->[1] = 'advanced_kde'
    #     $expected->[1] = 'client1'
    # Looks like you failed 1 test of 8.
#   Failed test 'edit mediums'
#   at ./t/ui/13-admin.t line 492.
Use of uninitialized value $expr in concatenation (.) or string at /usr/lib/perl5/5.18.2/B/Deparse.pm line 1370.
# Looks like you failed 1 test of 15.
Use of uninitialized value $expr in concatenation (.) or string at /usr/lib/perl5/5.18.2/B/Deparse.pm line 1370.
./t/ui/13-admin.t ....................
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/15 subtests

notes

History

#1 Updated by mkittler over 1 year ago

  • Target version set to Current Sprint

#2 Updated by EDiGiacinto over 1 year ago

Also https://github.com/os-autoinst/openQA/pull/1783 is affected by it (after rebasing)

#3 Updated by mkittler over 1 year ago

  • Status changed from New to In Progress

There is no AJAX involved in the relevant part of the JavaScript code. Adding a wait_for_ajax nervelessness or even a regular sleep doesn't work. So I still have no clue why the JavaScript behaves wrong when the tests are executed within Travis. But it seems like it is now almost reproducible 100 % of the time (within Travis).

If I don't get a clue soon, we could also temporarily make that test non-fatal. Better than having red status on each PR.

#4 Updated by mkittler over 1 year ago

  • Status changed from In Progress to Resolved

#5 Updated by coolo over 1 year ago

  • Target version changed from Current Sprint to Done

Also available in: Atom PDF