Project

General

Profile

Actions

action #42731

closed

coordination #40469: [functional][y][epic] Adjust RAID/LVM/partitioning tests to the new changes and extend testing coverage

[sle][functional][autoyast][y] AutoYaST: directly formatted disk or disk as MD member

Added by riafarov over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
SUSE QA - Milestone 26
Start date:
2018-10-19
Due date:
2019-07-30
% Done:

0%

Estimated time:
5.00 h
Difficulty:

Description

Motivation

Expert partitioner an AY now support using disks as Multiple Device member or as filesystem: https://w3.suse.de/%7Eigonzalezsosa/doc/book.autoyast/configuration.html#ay.use_whole_disk

Find more details in the trello card.

Acceptance criteria

  1. Functionality is evaluated manually covering potential regressions for the old format
  2. Autoyast installation using disk as filesystem and validation is automated and enabled in openQA for SLE 15 SP1
  3. Autoyast installation using disk as MD and validation is automated and enabled in openQA for SLE 15 SP1

Further details

Please, find profile templates in the attachment.
In validation we should check at least mount points and partitioning matches parameters in the profile.


Files

Actions #1

Updated by riafarov over 5 years ago

  • Subject changed from [sle][functional][y] AutoYaST: directly formatted disk or disk as MD member to [sle][functional][autoyast][y] AutoYaST: directly formatted disk or disk as MD member
  • Parent task set to #40469
Actions #2

Updated by okurz over 5 years ago

  • Subject changed from [sle][functional][autoyast][y] AutoYaST: directly formatted disk or disk as MD member to [sle][functional][autoyast][y] AutoYaST: directly formatted disk or disk as MD member
  • Category set to New test
Actions #3

Updated by okurz over 5 years ago

  • Target version set to Milestone 23
Actions #4

Updated by okurz about 5 years ago

  • Due date set to 2019-03-12
Actions #5

Updated by riafarov almost 5 years ago

  • Due date changed from 2019-03-12 to 2019-03-26

No capacity (missed to move during the planning).

Actions #6

Updated by riafarov almost 5 years ago

  • Description updated (diff)
  • Estimated time set to 5.00 h
Actions #7

Updated by okurz almost 5 years ago

  • Due date changed from 2019-03-26 to 2019-07-02
  • Target version changed from Milestone 23 to Milestone 26

Due to the effort estimation being a bit higher I suggest to plan that later, e.g. post SLE15SP1 GM

Actions #8

Updated by riafarov over 4 years ago

  • Due date changed from 2019-07-02 to 2019-07-16
Actions #9

Updated by oorlov over 4 years ago

  • Assignee set to oorlov
Actions #10

Updated by oorlov over 4 years ago

  • Status changed from Workable to In Progress
Actions #11

Updated by riafarov over 4 years ago

  • Due date changed from 2019-07-16 to 2019-07-30
Actions #12

Updated by oorlov over 4 years ago

  • Status changed from In Progress to Feedback
  1. I've manually tested, that the profile that was generated on Sle12 works on Sle15 as well;
  2. Autoyast installation using disk as filesystem is already covered in verify_disk_as_pv test scenario.

  3. PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7913

Actions #13

Updated by riafarov over 4 years ago

  • Status changed from Feedback to Resolved

updated integration level test plan accordingly.

Actions

Also available in: Atom PDF