Project

General

Profile

action #41840

[sle][s390x][s390-kvm][tools][ltp] Enable virtio_terminal console (VIRTIO_CONSOLE) on svirt backend

Added by pvorel almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Feature requests
Target version:
-
Start date:
2018-10-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
hard

Description

Some console based tests (e.g. LTP, but also others) use virtio terminal feature (os-autoinst/consoles/virtio_terminal.pm, VIRTIO_CONSOLE variable).
https://progress.opensuse.org/issues/14582
http://open.qa/docs/#_the_virtio_serial_terminal_implementation
https://w3.suse.cz/~rpalethorpe/training/serial-backend.html

This is based on qemu virtio serial terminal feature
https://fedoraproject.org/wiki/Features/VirtioSerial

It'd be nice if svirt backend (which uses SSH access to a libvirt running host - KVM for System Z in mind) allowed using this console as well, as it's much faster.

Tips in os-autoinst/consoles/virtio_terminal.pm:

This console can be requested when the backend (usually QEMU/KVM) and guest OS
support virtio serial and virtio console. The guest also needs to be in a state
where it can start a tty on the virtual console. By default openSUSE and SLE
automatically start agetty when the kernel finds the virtio console device, but
another OS may require some additional configuration.

It may also be possible to use a transport other than virtio. This code just
requires a UNIX socket which inputs and outputs terminal ASCII/ANSI codes.


Related issues

Is duplicate of openQA Project - action #36457: Implement serial terminal console for svirt backendResolved2018-05-23

History

#1 Updated by pvorel almost 3 years ago

  • Category set to 132
  • Difficulty set to hard

#3 Updated by coolo almost 3 years ago

  • Is duplicate of action #36457: Implement serial terminal console for svirt backend added

#4 Updated by coolo almost 3 years ago

  • Status changed from New to Rejected

I count your vote

#5 Updated by pvorel almost 3 years ago

#6 Updated by mkittler almost 3 years ago

A generic serial console has been implemented (not using the qemu specific virtio).

Also available in: Atom PDF