action #41771

[functional][sle][u][ppc64le] test fails in boot_to_desktop - QEMU PPC tests are not able to boot from parent's generated qcow2

Added by SLindoMansilla over 1 year ago. Updated 12 months ago.

Status:RejectedStart date:28/09/2018
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:
Duration:

Description

Observation

QEMU PPC tests are not able to boot from parent's generated qcow2

  • H1 The problem can be reproduced on a local openQA instance - SUPPORTED by E1
  • H2 The qcow2 image is defective - REJECTED by E2

  • E1 Clone the job to a local instance. (performed by zluo)

    • R1 Reproducible on local instance
  • E2 Manually boot from that qcow2 image outside openQA.

    • R2 zluo was able to boot from that qcow2 image on his pkvm.

Reproducible

Fails since (at least) Build 52.3. All child jobs are failing to boot:
- suse_patches-systemd_testsuite
- extra_tests_in_textmode
- extra_tests_filesystem
- toolchain_zypper

Expected result

Last good Build 50.1: extra_tests_filesystem

Further details

Always latest result in this scenario: latest

ppc64le.png (27 KB) zluo, 28/09/2018 01:36 pm

6833

History

#1 Updated by SLindoMansilla over 1 year ago

  • Description updated (diff)

#2 Updated by okurz over 1 year ago

  • Subject changed from [functional][sle][u] test fails in boot_to_desktop - QEMU PPC tests are not able to boot from parent's generated qcow2 to [functional][sle][u][ppc64le] test fails in boot_to_desktop - QEMU PPC tests are not able to boot from parent's generated qcow2
  • Target version set to future

#3 Updated by SLindoMansilla over 1 year ago

  • Description updated (diff)
  • Reproducible on local openQA instance.
  • zluo was able to boot from that qcow2 image on his pkvm.

#4 Updated by SLindoMansilla over 1 year ago

  • Description updated (diff)

#5 Updated by szarate over 1 year ago

On a note here: Try to use the same version or similar version of qemu that the production workers have... 3.0 seems problematic

#6 Updated by zluo over 1 year ago

During the test at early stage, I can see that only CD-ROM device found.

But after Welcome to Open Firmware, it tries to load: from: /pci@80000020000000/scsi@5 ..
E2404: Not a bootable device!

...

E3407: Load failed

scsi@5 doesn't exist. To me it seems that hard disk (partition with GRUB) is not available at that time.

#7 Updated by zluo over 1 year ago

During the test at early stage, I can see that only CD-ROM device found.

But after Welcome to Open Firmware, it tries to load: from: /pci@80000020000000/scsi@5 ..
E2404: Not a bootable device!

...

E3407: Load failed

scsi@5 doesn't exist. To me it seems that hard disk (partition with GRUB) is not available at that time.

#9 Updated by zluo over 1 year ago

http://e13.suse.de/tests/8739 shows no issue with parent's generated qcow2. This is successful because of older qemu version. It still won't work if qemu version got updated to 3.0.

#10 Updated by okurz 12 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz

Also available in: Atom PDF