Project

General

Profile

action #41756

module "failed_module" on /tests/overview does not show latest in each build / does not resolve latest build

Added by okurz almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2018-09-28
Due date:
% Done:

0%

Estimated time:
Difficulty:
medium

Description

Observation

Currently https://openqa.suse.de/tests/overview?arch=&version=15-SP1&build=52.3&distri=sle&groupid=110# shows no modules failing in "releasenotes" but https://openqa.suse.de/tests/overview?arch=&failed_modules=releasenotes&version=15-SP1&build=52.3&distri=sle&groupid=110# shows older tests within the same build.

Expected result

  • "failed_modules" should show the latest jobs within each build
  • using a query with "failed_modules" and no build specified should resolve to the latest jobs within the latest build

History

#1 Updated by coolo almost 2 years ago

  • Target version set to Ready
  • Difficulty set to medium

Note that the ISO was rescheduled, so there is no clone_id.

#2 Updated by okurz almost 2 years ago

true but I think I have observed the same observation on real clones

#3 Updated by mkittler almost 2 years ago

  • Status changed from New to Feedback
  • Assignee set to mkittler

I could not reproduce the issue with real clones. For instance https://openqa.suse.de/tests/overview?arch=&failed_modules=scc_registration&version=15-SP1&build=24.13&distri=sle&groupid=110 doesn't show https://openqa.suse.de/tests/2002212#next_previous.

However, after discussing the issue with okurz, it seems filtering (to be useful in practice) should never reveal a job which would be displayed in the unfiltered table - also if there is no clone_id.

coolo From your previous comment I figure that for you the current behavior is the expected behavior (unless the issue also affects cases where clone_id is set). So before adjusting the filtering in the way okurz wants it to work, would that be ok for you?

#4 Updated by coolo almost 2 years ago

I'm saying that the issue not high prio as the circumstances are special. But I agree that tests/overview filtering should not show more tests than not filtering.

#5 Updated by mkittler almost 2 years ago

  • Status changed from Feedback to In Progress

good use case for test driven development: https://github.com/os-autoinst/openQA/pull/1852

#6 Updated by mkittler almost 2 years ago

  • Target version changed from Ready to Current Sprint

#7 Updated by mkittler almost 2 years ago

  • Status changed from In Progress to Resolved

PR has been merged

#8 Updated by okurz almost 2 years ago

Thank you so far. I guess we need to give it some time until we have enough feedback from production to be able to say it's "done done" :)

#9 Updated by coolo almost 2 years ago

  • Target version changed from Current Sprint to Done

Also available in: Atom PDF