Project

General

Profile

action #41357

[functional][y] test fails in partitioning_lvm_thin_provisioning - the warning window is part of newer storage-ng update which is not ready yet for TW

Added by mlin7442 about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 20
Start date:
2018-09-20
Due date:
2018-10-23
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-lvm_thin_provisioning@64bit fails in
partitioning_lvm_thin_provisioning

Until https://build.opensuse.org/request/show/636678 be merging to Factory, we will not have that warning window pop-up, perhaps we need a check_screen there.

NOTE: if latest build still fails, please, do not work on the ticket.

Reproducible

Fails since (at least) Build 20180918

Expected result

Last good: 20180917 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 4 years ago

  • Subject changed from test fails in partitioning_lvm_thin_provisioning - the warning window is part of newer storage-ng update which is not ready yet for TW to [functional][y] test fails in partitioning_lvm_thin_provisioning - the warning window is part of newer storage-ng update which is not ready yet for TW
  • Due date set to 2018-10-09
  • Priority changed from Normal to High
  • Target version set to Milestone 20

mloviska is this related to your recent addition of partitioning_lvm_thin_provisioning? It looks like the product behaviour did not change but the test code expects something different now?

#2 Updated by riafarov about 4 years ago

  • Status changed from New to Workable

#3 Updated by mloviska about 4 years ago

okurz, we are missing a pop up warning which has been already deployed on other storage-ng systems. leap15.1 & sle15sp1

#4 Updated by mloviska about 4 years ago

#5 Updated by okurz about 4 years ago

I see, interesting.

#6 Updated by riafarov about 4 years ago

  • Status changed from Workable to Blocked
  • Assignee set to riafarov

Waiting to get change to the Factory.

#8 Updated by riafarov about 4 years ago

Again SR failed for Factory...

#9 Updated by mloviska about 4 years ago

Most recent failed again for factory https://build.opensuse.org/request/show/639006#

#14 Updated by riafarov about 4 years ago

  • Description updated (diff)
  • Due date changed from 2018-10-09 to 2018-10-23
  • Status changed from Blocked to Workable
  • Assignee deleted (riafarov)

Should reach next build of TW.

NOTE: if latest build still fails, please, do not work on the ticket.

#15 Updated by riafarov about 4 years ago

Test module also fails in leap, as now overview tab is selected by default.

#17 Updated by mloviska about 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to mloviska

#18 Updated by mloviska about 4 years ago

Tests are currently failing to add VGs sle-15-SP1-Installer-DVD-x86_64-Build63.1-lvm_thin_provisioning@64bit & opensuse-15.1-DVD-x86_64-Build312.1-lvm_thin_provisioning@64bit.

Regarding TW, test runs fine because of latest PRs ( including not merged 5902 )

#20 Updated by mloviska about 4 years ago

  • Status changed from In Progress to Resolved

https://build.opensuse.org/request/show/642396

Currently the code contains updates for new storage-ng as well as it contains the old one.

o3 VRs:

Also available in: Atom PDF