Project

General

Profile

action #40916

[qam] [12sp3] test scc_registration fails in several scenarios: unable to add web and scripting module

Added by kgw_suse about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-09-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-Updates-x86_64-qam-allpatterns+addons@64bit fails in
scc_registration

openQA test in scenario sle-12-SP3-Server-DVD-Incidents-x86_64-mru-install-minimal-with-addons@64bit fails in
scc_registration

Reproducible

Fails since (at least) Build 20180910-3

Frequent such fails since yesterday, Sep 11, 2018:

At least eleven such fails are listed on https://openqa.suse.de/tests/2039167#next_previous for scenario: sle-12-SP3-Server-DVD-Updates-x86_64-qam-allpatterns+addons@64bit

At least seven such fails are listed on https://openqa.suse.de/tests/2039193#next_previous for scenario: sle-12-SP3-Server-DVD-Incidents-x86_64-mru-install-minimal-with-addons@64bit

Expected result

Last good: 20180910-2 (or more recent)

Further details

Always latest result in this scenario: latest

Analysis (riafarov, on #testing)

we cannot find web and scripting module. ... I guess we don't scroll [down]
enough. [References:]

https://openqa.suse.de/tests/2037172#step/scc_registration/108
https://openqa.suse.de/tests/2037593#step/scc_registration/125

I would try to increase number of steps in send_key_until_needlematch we have here:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/registration.pm#L343


Related issues

Has duplicate openQA Tests - action #40961: test fails in scc_registrationRejected2018-09-13

History

#1 Updated by okurz about 3 years ago

I fail to see the cursor in the screenshots when going down. Looks like the scroll bar moves slightly with pressing "down" keys but the entries are not visible. Maybe it is just as simple as increasing the limit for the down-key

#2 Updated by kgw_suse about 3 years ago

A testrun cloned from https://openqa.suse.de/tests/2039193 on my own openQA instance modified by the following simple patch looks indeed promising: http://mime.qam.suse.de/tests/60. Work in progress. Something else than the random choice of "30" might be more suitable.

--- /var/lib/openqa/share/tests/os-autoinst-distri-opensuse/lib/registration.pm--180911-git.010c5f68        2018-09-12 14:55:57.000000000 +0200
+++ /var/lib/openqa/share/tests/os-autoinst-distri-opensuse/lib/registration.pm     2018-09-12 15:42:04.243462963 +0200
@@ -340,7 +340,8 @@
                             next;
                         }
                     }
-                    send_key_until_needlematch ["scc-module-$addon", "scc-module-$addon-selected"], "down";
+                    # Default attempts counter of 20 is not enough; the modules list may be too long!
+                    send_key_until_needlematch ["scc-module-$addon", "scc-module-$addon-selected"], "down", 30;
                     if (match_has_tag("scc-module-$addon")) {
                         # checkmark the requested addon
                         assert_and_click "scc-module-$addon";

#3 Updated by coolo about 3 years ago

  • Has duplicate action #40961: test fails in scc_registration added

#4 Updated by coolo about 3 years ago

That's 50% more - that will do for a while :)

#5 Updated by jbaier_cz about 3 years ago

  • Status changed from New to In Progress

#6 Updated by jbaier_cz about 3 years ago

  • Assignee set to jbaier_cz

#7 Updated by kgw_suse about 3 years ago

Submitted pull request https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5763
(with 40 rather than 30, agreeing with jbaier_cz).

#8 Updated by jbaier_cz about 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF