Project

General

Profile

action #40655

[tools][ipmi] DIE The console isn't responding correctly. Maybe half-open socket? at /usr/lib/os-autoinst/backend/baseclass.pm line 241

Added by waynechen55 about 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-09-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-x86_64-prj2_host_upgrade_developing_to_sles15_xen@64bit-ipmi fails in
reboot_after_installation

Reproducible

Fails since (at least) Build 0374

Expected result

Last good: 0371 (or more recent)

Further details

Always latest result in this scenario: latest

Log snippet

[2018-09-06T06:51:59.0435 CEST] [debug] waiting for screen change: 0 1000000
BYTES {"similiarity_to_reference":{"json_cmd_token":"HnTbKGDN"},"json_cmd_token":"OUipHAuq"}
DIE The console isn't responding correctly. Maybe half-open socket? at /usr/lib/os-autoinst/backend/baseclass.pm line 241.

at /usr/lib/os-autoinst/backend/baseclass.pm line 80.
backend::baseclass::die_handler('The console isn\'t responding correctly. Maybe half-open sock...') called at /usr/lib/os-autoinst/backend/baseclass.pm line 241
eval {...} called at /usr/lib/os-autoinst/backend/baseclass.pm line 156
backend::baseclass::run_capture_loop('backend::ipmi=HASH(0x756c198)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 129
backend::baseclass::run('backend::ipmi=HASH(0x756c198)', 13, 16) called at /usr/lib/os-autoinst/backend/driver.pm line 77
backend::driver::ANON('Mojo::IOLoop::ReadWriteProcess=HASH(0x6643dc0)') called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 309
eval {...} called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 309
Mojo::IOLoop::ReadWriteProcess::fork('Mojo::IOLoop::ReadWriteProcess=HASH(0x6643dc0)', 'CODE(0x2225c20)') called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 445
Mojo::IOLoop::ReadWriteProcess::start('Mojo::IOLoop::ReadWriteProcess=HASH(0x6643dc0)') called at /usr/lib/os-autoinst/backend/driver.pm line 79
backend::driver::start('backend::driver=HASH(0x63ca5e0)') called at /usr/lib/os-autoinst/backend/driver.pm line 50
backend::driver::new('backend::driver', 'ipmi') called at /usr/bin/isotovideo line 199
main::init_backend() called at /usr/bin/isotovideo line 267
[2018-09-06T06:54:15.0232 CEST] [debug] IPMI: Chassis Power Control: Down/Off
last frame
[2018-09-06T06:54:15.0293 CEST] [debug] sending magic and exit
[2018-09-06T06:54:15.0294 CEST] [debug] received magic close
[2018-09-06T06:54:15.0294 CEST] [debug] THERE IS NOTHING TO READ 15 4 3
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":56817"
after 2521 requests (2521 known processed) with 0 events remaining.
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":33369"
after 2680 requests (2680 known processed) with 0 events remaining.
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":48181"
after 2659 requests (2659 known processed) with 0 events remaining.
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":46821"
after 2680 requests (2523 known processed) with 0 events remaining.
[2018-09-06T06:54:15.0315 CEST] [debug] backend process exited: 0
[2018-09-06T06:54:15.0316 CEST] [debug] Driver backend collected unknown process with pid 6840 and exit status: 1
[2018-09-06T06:54:15.0316 CEST] [debug] Driver backend collected unknown process with pid 5069 and exit status: 1
[2018-09-06T06:54:15.0316 CEST] [debug] Driver backend collected unknown process with pid 4292 and exit status: 1
[2018-09-06T06:54:15.0317 CEST] [debug] Driver backend collected unknown process with pid 6865 and exit status: 1
xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":56817"
xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":33369"
xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":48181"
[2018-09-06T06:54:15.0320 CEST] [debug] Driver backend collected unknown process with pid 6845 and exit status: 255
xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":46821"
[2018-09-06T06:54:15.0321 CEST] [debug] Driver backend collected unknown process with pid 6867 and exit status: 84
[2018-09-06T06:54:15.0321 CEST] [debug] Driver backend collected unknown process with pid 6869 and exit status: 0
[2018-09-06T06:54:15.0321 CEST] [debug] Driver backend collected unknown process with pid 5071 and exit status: 84
[2018-09-06T06:54:15.0321 CEST] [debug] Driver backend collected unknown process with pid 6842 and exit status: 84
[2018-09-06T06:54:15.0321 CEST] [debug] commands process exited: 0
[2018-09-06T06:54:15.0321 CEST] [debug] Driver backend collected unknown process with pid 6844 and exit status: 0
[2018-09-06T06:54:15.0324 CEST] [debug] Driver backend collected unknown process with pid 4294 and exit status: 84
[2018-09-06T06:54:15.0324 CEST] [debug] Driver backend collected unknown process with pid 4304 and exit status: 0
[2018-09-06T06:54:15.0325 CEST] [debug] sysread failed:
[2018-09-06T06:54:15.0326 CEST] [debug] syswrite failed Broken pipe at /usr/lib/os-autoinst/myjsonrpc.pm line 38.
myjsonrpc::send_json('GLOB(0x35b6c58)', 'HASH(0x316e320)') called at /usr/lib/os-autoinst/autotest.pm line 282
autotest::query_isotovideo('backend_last_screenshot_data') called at /usr/lib/os-autoinst/basetest.pm line 498
basetest::_result_add_screenshot('reboot_after_installation=HASH(0x63ba638)', 'HASH(0x698f178)') called at /usr/lib/os-autoinst/basetest.pm line 350
basetest::runtest('reboot_after_installation=HASH(0x63ba638)') called at /usr/lib/os-autoinst/autotest.pm line 328
eval {...} called at /usr/lib/os-autoinst/autotest.pm line 327
autotest::runalltests() called at /usr/lib/os-autoinst/autotest.pm line 183
eval {...} called at /usr/lib/os-autoinst/autotest.pm line 183
autotest::run_all() called at /usr/lib/os-autoinst/autotest.pm line 236
autotest::
ANON_('Mojo::IOLoop::ReadWriteProcess=HASH(0x654e098)') called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 309
eval {...} called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 309
Mojo::IOLoop::ReadWriteProcess::_fork('Mojo::IOLoop::ReadWriteProcess=HASH(0x654e098)', 'CODE(0x64b0b18)') called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 445
Mojo::IOLoop::ReadWriteProcess::start('Mojo::IOLoop::ReadWriteProcess=HASH(0x654e098)') called at /usr/lib/os-autoinst/autotest.pm line 237
autotest::start_process() called at /usr/bin/isotovideo line 265

[2018-09-06T06:54:15.0327 CEST] [debug] Driver backend collected unknown process with pid 6821 and exit status: 0


Related issues

Related to openQA Project - action #31543: [sles][functional][tools][s390x][ipmi][hard][sporadic] test incompletes - "DIE The console isn't responding correctly. Maybe half-open socket?"Resolved2018-02-082018-03-13

Is duplicate of openQA Tests - action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMIResolved2018-03-05

History

#1 Updated by okurz about 2 years ago

  • Related to action #31543: [sles][functional][tools][s390x][ipmi][hard][sporadic] test incompletes - "DIE The console isn't responding correctly. Maybe half-open socket?" added

#2 Updated by okurz about 2 years ago

  • Related to action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMI added

#3 Updated by okurz about 2 years ago

  • Subject changed from DIE The console isn't responding correctly. Maybe half-open socket? at /usr/lib/os-autoinst/backend/baseclass.pm line 241 to [tools][ipmi] DIE The console isn't responding correctly. Maybe half-open socket? at /usr/lib/os-autoinst/backend/baseclass.pm line 241

Looks like a duplicate of #32746 , is it?

#4 Updated by michalnowak almost 2 years ago

  • Related to deleted (action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMI)

#5 Updated by michalnowak almost 2 years ago

  • Is duplicate of action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMI added

#6 Updated by michalnowak almost 2 years ago

  • Status changed from New to Rejected

Duplicate of #32746.

Also available in: Atom PDF