Project

General

Profile

action #40640

[functional][u] MinimalX newly uses lightdm, no longer xdm

Added by dimstar over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 19
Start date:
2018-09-05
Due date:
2018-09-25
% Done:

0%

Estimated time:
3.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-create_hdd_minimalx@64bit fails in
first_boot

Reproducible

Fails since (at least) Build 20180904 (current job)

Expected result

Last good: 20180903 (or more recent)

Further details

Always latest result in this scenario: latest

The product has changed the DM from XDM to LightDM for the minimal case (XDM is really too limited in almost all cases and thus it made sense to perform this switch)

This in turn requires openQA to catch up with this change in order to correctly preform the login.

Since MinimalX is used as a base for a lot of the tests, this change is urgently needed

History

#1 Updated by okurz over 4 years ago

  • Subject changed from MinimalX newly uses lightdm, no longer xdm to [functional][u] MinimalX newly uses lightdm, no longer xdm
  • Due date set to 2018-09-25
  • Status changed from New to Workable
  • Target version set to Milestone 19

#2 Updated by mgriessmeier over 4 years ago

  • Estimated time set to 3.00 h

might be just a "trivial needle update" but could also need functional changes

#3 Updated by zluo over 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and checking

#4 Updated by zluo over 4 years ago

  • Status changed from In Progress to Resolved

https://openqa.opensuse.org/tests/754201#step/first_boot/1 shows no issue anymore, lightdm is already used here.

my local test shows also successful tests result for first_boot.

Also available in: Atom PDF