Project

General

Profile

tickets #39866

o3 unable to send any mail, "Domain not found"

Added by okurz about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Servers hosted in NBG
Target version:
-
Start date:
2018-08-16
Due date:
% Done:

0%

Estimated time:

Description

Observation

Output from system journal

Aug 16 14:27:06 ariel postfix/smtp[29928]: 3271E194FE: host mx1.suse.de[195.135.220.2] said: 450 4.1.8 <openqa-monitor@ariel.infra.opensuse.org>: Sender address rejected: Domain not found (in reply to RCPT TO command)
…
Aug 16 14:27:33 ariel postfix/smtp[29928]: 3271E194FE: to=<okurz@suse.de>, relay=mx2.suse.de[195.135.220.15]:25, delay=1051, delays=954/53/26/18, dsn=4.1.8, status=deferred (host mx2.suse.de[195.135.220.15] said: 450 4.1.8 <openqa-monitor@ariel.infra.opensuse.org>: Sender address rejected: Domain not found (in reply to RCPT TO command))
…
Aug 16 14:27:36 ariel postfix/smtp[29927]: F1B18194EC: to=<szarate@suse.de>, relay=mx2.suse.de[195.135.220.15]:25, delay=65852, delays=65753/53/27/19, dsn=4.1.8, status=deferred (host mx2.suse.de[195.135.220.15] said: 450 4.1.8 <openqa-monitor@ariel.infra.opensuse.org>: Sender address rejected: Domain not found (in reply to RCPT TO command))

Problem

Seems like the mail recipient is not properly configured


Related issues

Related to openQA Project - action #39743: [o3][tools] o3 unusable, often responds with 504 Gateway Time-outResolved2018-08-15

History

#1 Updated by okurz about 3 years ago

  • Private changed from Yes to No

#2 Updated by pjessen about 3 years ago

ariel should probably be relaying outbound mail via relay.infra.opensuse.org ?

relayhost = [relay.infra.opensuse.org]

#3 Updated by tampakrap about 3 years ago

  • Status changed from New to Closed
  • Assignee set to tampakrap

@Per, no, it is in a different network

@Oliver: here's what I did:

  • /etc/sysconfig/postfix: POSTFIX_RELAYHOST="[192.168.254.4]"
  • /etc/postfix/main.cf:
    • myhostname = openqa.opensuse.org
    • relayhost = 192.168.254.4

The sendmail command now works eg sendmail -f tchatzimichos@suse.de -bv tampakrap@opensuse.org so I suppose the automated mails should also work, let me know if they don't

#4 Updated by okurz about 3 years ago

Yes, I have received mails (probably since about a year or so).

@foursixnine has confirmed to have received mails as well

Errors from system journal also confirm that the issue is gone.

Thanks.

#5 Updated by okurz about 3 years ago

  • Related to action #39743: [o3][tools] o3 unusable, often responds with 504 Gateway Time-out added

Also available in: Atom PDF