Project

General

Profile

action #39665

[functional][u][ipmi] test fails in system_prepare, /dev/sshserial is used instead of /dev/ttyS1

Added by riafarov almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 19
Start date:
2018-08-13
Due date:
2018-09-25
% Done:

0%

Estimated time:
Difficulty:
Duration: 32

Description

Observation

We haven't reached this step for quite a while, somehow ensure_serialdev_permissions uses wrong serial device to set permissions.

openQA test in scenario sle-12-SP4-Server-DVD-x86_64-default@64bit-ipmi fails in
system_prepare

Acceptance Criteria

AC1: Regression is removed or properly handled

Reproducible

Fails since (at least) Build 0235

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #30613: [functional][y][hard] script_output might include extra serial outputResolved2018-01-222018-08-28

History

#1 Updated by riafarov almost 2 years ago

  • Related to action #30613: [functional][y][hard] script_output might include extra serial output added

#2 Updated by okurz almost 2 years ago

  • Due date set to 2018-09-25
  • Target version set to Milestone 19

related #30613 fixed, now on to this one

#3 Updated by zluo almost 2 years ago

  • Assignee set to zluo

#4 Updated by mgriessmeier almost 2 years ago

  • Due date changed from 2018-09-25 to 2018-09-11
  • Priority changed from Normal to High

blocking current tickets - moving to current sprint and raising priority

#5 Updated by mgriessmeier almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#6 Updated by zluo almost 2 years ago

  • Status changed from Workable to In Progress

http://openqa.suse.de/tests/1909195

still doesn't have system_prepare test module. So it means it has never worked before on ipmi machine.

#7 Updated by zluo almost 2 years ago

Why prepare_system got added for default ipmi?

#10 Updated by mgriessmeier almost 2 years ago

  • Status changed from In Progress to Feedback

Thanks to great effort of zaoliang we've found the reason why this never worked on ipmi.
the necessary function use_ssh_serial_console' was never called after the actual reboot, instead we tried to switch toroot-console` which does not work on ipmi

PR created: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5707

#11 Updated by zluo almost 2 years ago

  • Status changed from Feedback to Resolved

#12 Updated by okurz almost 2 years ago

  • Due date changed from 2018-09-11 to 2018-09-25
  • Status changed from Resolved to Feedback

Please clarify if select_console 'root-console' can work at all on IPMI. It was working and it should be working. If it is not working anymore then we should find out the reason why (since when) and make sure it works. Every backend should have a workable 'root-console'. If it works on s390x z/VM then I am sure we can make it work on IPMI as well :)

#13 Updated by zluo almost 2 years ago

okurz system_prepare has never tested and worked on ipmi before and please see also comment#10. Please provide "It was working" example for ipmi so I can see the difference...

mgriessmeier if you have something to clarify this, please let us know, thanks!

#14 Updated by mgriessmeier almost 2 years ago

  • Status changed from Feedback to Resolved

okurz wrote:

Please clarify if select_console 'root-console' can work at all on IPMI. It was working and it should be working. If it is not working anymore then we should find out the reason why (since when) and make sure it works. Every backend should have a workable 'root-console'. If it works on s390x z/VM then I am sure we can make it work on IPMI as well :)

root-console is working in general on ipmi, see further consoletests, they all use root-console
but use_ssh_serial_console is doing more stuff then just selecting root-ssh - the important part why we need to call this function is the disabling of the sol console and the change of the serial dev

Also available in: Atom PDF