Project

General

Profile

action #38966

[qam] test fails in firefox - tracking protection window appears after pop up check

Added by vsvecova almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-07-31
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-Staging:B-x86_64-gnome@64bit-staging fails in
firefox

The tracking protection information window appears later in the test, after the pop up check has already finished, so it does not get caught and handled and blocks matching areas for other needles.
The window pops up at different points (straight after pop up check; after version check etc.)

Sometimes a simple retrigger of the test helps, but not always; the failure is intermittent and fails about half of the times.

Occurs in SLE15-SP1; SLE12* and SLE15-GA are fine.

Reproducible

Fails since (at least) Build B.13.7 (current job)

Expected result

Last good: B.13.6 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 4 years ago

  • Subject changed from test fails in firefox - tracking protection window appears after pop up check to [qam] test fails in firefox - tracking protection window appears after pop up check

vsvecova while this issue was first observed in 15-SP1 I still set the qam label because you reported and picked it up. The latest job in the mentioned scenario is https://openqa.suse.de/tests/1891027 and soft-failed stable again.

Couldn't find a related PR. Did you change something or was it just an intermittent failure?

#2 Updated by vsvecova almost 4 years ago

Hi okurz, no, I have not submitted any PR. I have been monitoring the issue though, and I have noticed that it still appears intermittently, but not as often.

I noticed it failing in one or two cases (out of ~20) even in QAM tests on SLE15-GA. A re-run mostly fixes it, which testifies about its randomness.

I'll still keep a corner of an eye on it, just in case it starts appearing more frequently.

#3 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: lvm-full-encrypt
https://openqa.suse.de/tests/2016348

#4 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: lvm
https://openqa.suse.de/tests/2075044

#5 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: registered+gnome+dev_tools_all_packages_dvd
https://openqa.suse.de/tests/2166427

#6 Updated by dzedro over 3 years ago

  • Assignee changed from vsvecova to dzedro

#7 Updated by dzedro over 3 years ago

  • Status changed from New to In Progress

#8 Updated by dzedro over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

fixed

Also available in: Atom PDF