Project

General

Profile

action #38765

[openqa][ipmi] "logs_from_installation_system" step failed due to couldn't "get_installation_partition" when the system isn't in /dev/sda partition

Added by cachen about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-07-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

https://openqa.nue.suse.com/tests/1853694#step/logs_from_installation_system/11

Similar failure happens quite often on the servers, which has multi hard disks.

diff --git a/lib/ipmi_backend_utils.pm b/lib/ipmi_backend_utils.pm
index 18830256..7a78c963 100644
--- a/lib/ipmi_backend_utils.pm
+++ b/lib/ipmi_backend_utils.pm
@@ -146,7 +146,7 @@ sub umount_installation_disk {
}

sub get_installation_partition {

  • my $partition = script_output("fdisk -l | grep \"\/dev\/sda.*\*\" | cut -d ' ' -f 1");
  • my $partition = script_output("fdisk -l | grep \"\/dev\/sd.*\*\" | cut -d ' ' -f 1"); return $partition; }

This may fix the issue, but I have test in openQA.

History

#1 Updated by cachen about 3 years ago

BTW, this issue made many noisy to virtualization testing. But as Alice investigated, it also may caused by bug https://bugzilla.suse.com/show_bug.cgi?id=1101806.

#2 Updated by mitiao about 3 years ago

  • Project changed from openQA Project to openQA Tests

#3 Updated by cachen about 3 years ago

  • Priority changed from High to Normal

confirmed by manually check, the root cause is as bug1101806 described 'fdisk -l' didn't present the correct installation partition in openqaworker2:24 server:

Wrong marked in sdd1:
Device Boot Start End Sectors Size Id Type
/dev/sdd1 * 2048 83892223 83890176 40G 83 Linux
/dev/sdd2 83892224 1172121599 1088229376 518.9G 83 Linux

It should in sda2, but got wrong information:
Device Start End Sectors Size Type
/dev/sda1 2048 16383 14336 7M BIOS boot
/dev/sda2 16384 468860927 468844544 223.6G Microsoft basic data

Refers to:
df -h
/dev/sda2 224G 186M 223G 1% /mnt

So, this failure will block xen tests on this server until the bug get fixed, otherwise perhaps we can find a workaround?

#4 Updated by okurz about 3 years ago

  • Category set to Bugs in existing tests

#5 Updated by jbaier_cz almost 3 years ago

Just a wild guess, this might be already fixes by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5739

#6 Updated by okurz almost 3 years ago

  • Status changed from New to Resolved
  • Assignee set to jbaier_cz

I think so as well. Anyone minds when I close this ticket?

Also available in: Atom PDF