Project

General

Profile

action #38480

[functional][u][fast][qam] job mau-extratests fails in new tests update_alternatives, aplay, openssl_alpn, curl_ipv6, wget_ipv6, gpg, shells

Added by kgw_suse about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 18
Start date:
2018-07-17
Due date:
2018-07-31
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario

sle-12-SP2-Server-DVD-Updates-x86_64-mau-webserver@64bit

fails in several tests involving a non-root console:

Reproducible

Fails since (at least) Build [20180717-2]
The reason is obvious: a non-root user is usually not permitted to write to /dev/ttyS0.

Expected result
Last "good" (above tests not present yet):

SLE-12-SP2 Build 20180717-1

https://openqa.suse.de/tests/1833122


Related issues

Related to openQA Project - action #30613: [functional][y][hard] script_output might include extra serial outputResolved2018-01-222018-08-28

Related to openQA Tests - action #38525: [sle]][functional][u][fast] test fails in boot_to_desktop - booting is not completedResolved2018-07-182018-07-31

Related to openQA Tests - action #37027: [tw][desktop] Update create_hdd_* to make sure right permissionsResolved2018-06-11

History

#1 Updated by kgw_suse about 3 years ago

  • Assignee set to okurz

Tentatively assigned to okurz, since tests curl_ipv6.pm and wget_ipv6.pm contain the possibly problematic code

select_console 'user-console';
assert_script_run(...);

Same also in update_alternatives.pm

#2 Updated by okurz about 3 years ago

  • Related to action #30613: [functional][y][hard] script_output might include extra serial output added

#3 Updated by okurz about 3 years ago

  • Related to action #38525: [sle]][functional][u][fast] test fails in boot_to_desktop - booting is not completed added

#4 Updated by okurz about 3 years ago

  • Related to action #37027: [tw][desktop] Update create_hdd_* to make sure right permissions added

#5 Updated by okurz about 3 years ago

  • Subject changed from [qam] job mau-extratests fails in new tests update_alternatives, aplay, openssl_alpn, curl_ipv6, wget_ipv6, gpg, shells to [functional][u][fast][qam] job mau-extratests fails in new tests update_alternatives, aplay, openssl_alpn, curl_ipv6, wget_ipv6, gpg, shells
  • Description updated (diff)
  • Due date set to 2018-07-31
  • Category set to Bugs in existing tests
  • Status changed from New to Feedback
  • Priority changed from Normal to High
  • Target version set to Milestone 18

Just what I thought, caused by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5387 . I reverted that PR by yuanren10 . https://openqa.suse.de/tests/1848577 is a new job in the mentioned scenario currently scheduled. Other failures can be retriggered as well.

#6 Updated by okurz about 3 years ago

  • Status changed from Feedback to Resolved

https://openqa.suse.de/tests/1848577 did not fail so I guess we are good for the time being.

Also available in: Atom PDF