action #38447

"developer mode" on o3 does not seem to ever update the "current test module" and is stuck in "retrieving status"

Added by okurz over 1 year ago. Updated over 1 year ago.

Status:ResolvedStart date:16/07/2018
Priority:NormalDue date:
Assignee:mkittler% Done:

0%

Category:Concrete Bugs
Target version:Done
Difficulty:
Duration:

Description

Steps to reproduce

what works to reproduce the issue at least for me:

  • Trigger any test on o3
  • Switch to "live view"
  • Observe that the content never changes from "retrieving status" and "establishing connection to backend…"

Further details

Same for firefox as well as chromium. Could it be related to the o3 workers being in a restricted network?

History

#1 Updated by coolo over 1 year ago

  • Assignee set to mkittler
  • Target version set to Current Sprint

the browser refuses to mix https and unencrypted websocket. Marius is already working on that

#2 Updated by mkittler over 1 year ago

  • Status changed from New to In Progress

#3 Updated by mkittler over 1 year ago

Using a secure connection was one (easy) thing to fix.

But since we're using the worker on openqaworker11 (instead of openqaworker12) for the staging instance e212 the proxy can't reach the os-autoinst command server anymore. So on e212 I'm currently seeing this error regardless whether TLS is used or not.

#4 Updated by mkittler over 1 year ago

  • Status changed from In Progress to Feedback

The problem on staging was just caused by the firewall. Apparently openqaworker11 is not setup using our salt recipe so the ports for the os-autoinst command server where not open. So I'd say it is fixed. Let's see whether it works in production as well.

#5 Updated by mkittler over 1 year ago

  • Status changed from Feedback to Resolved

Works now since o3 has been updated and livehandler daemon enabled. (Maybe not all worker might be setup correctly yet.)

#6 Updated by coolo over 1 year ago

  • Target version changed from Current Sprint to Done

Also available in: Atom PDF