Project

General

Profile

action #35674

[functional][u][leap] test fails in NM_wpa2_enterprise - needs update for Leap 15.0

Added by lnussel about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-04-29
Due date:
2018-06-19
% Done:

0%

Estimated time:
Difficulty:
Duration: 37

Description

Observation

openQA test in scenario opensuse-15.0-DVD-x86_64-extra_tests_on_gnome@64bit fails in
NM_wpa2_enterprise

The test basically cannot work. The gnome image uses wicked. The laptop tests that would have Networkmanager don't work due to lack of workers that don't crash the tests.

So please remove the test from extra_tests_on_gnome and move it to the (not working) laptop test for gnome. -> Wrong: The test can work but needs an update for openSUSE Leap 15.0 at least regarding needles.

Reproducible

Fails since (at least) Build 105.1

Expected result

See corresponding openSUSE Tumbleweed scenario.

Suggestions

  • DONE: Create needles for openSUSE Leap 15.0
  • Add proper flags to the setup test modules, e.g. hwsim_wpa2_enterprise_setup and yast2_network_setup to not try to execute NM_wpa2_enterprise which can not work

Further details

Always latest result in this scenario: latest

History

#1 Updated by lnussel about 2 years ago

  • Difficulty set to easy

#2 Updated by okurz about 2 years ago

So what changed it so that the test can not work anymore? https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3303 added the test originally. What has changed since then or what was wrong initially but why did it not fail then?

#3 Updated by okurz about 2 years ago

  • Subject changed from test fails in NM_wpa2_enterprise to [functional][u] test fails in NM_wpa2_enterprise - do we need to use a laptop base image with NetworkManager enabled by default?
  • Due date set to 2018-06-05
  • Target version set to Milestone 16
  • Difficulty deleted (easy)

#4 Updated by dheidler about 2 years ago

Also the hwsim_wpa2_enterprise_setup and yast2_network_setup modules are missing proper testflags.
As they rely on each other at least the first two need to be given the fatal flag.

#5 Updated by okurz about 2 years ago

  • Subject changed from [functional][u] test fails in NM_wpa2_enterprise - do we need to use a laptop base image with NetworkManager enabled by default? to [functional][u][leap] test fails in NM_wpa2_enterprise - needs update for Leap 15.0
  • Description updated (diff)
  • Status changed from New to In Progress
  • Assignee set to okurz

I guess the whole initial report is misleading and dheidler is on the right track - lnussel is not: The test can very well work in principle and please do not overlook that it progresses further in openSUSE Tumbleweed and also it worked. https://openqa.opensuse.org/tests/665447#step/yast2_network_setup/15 is the very next step to look into, simple needle mismatch due to font differences to openSUSE Tumbleweed …

lnussel I suggest to always look for a proper reference job. We do not add tests that never worked so there must always be a reference as base of comparison. In this case it can be found over https://openqa.opensuse.org/tests?match=extra_tests_on_gnome showing e.g. the most recent openSUSE Tumbleweed job that can select the wifi as expected, see https://openqa.opensuse.org/tests/666040#step/NM_wpa2_enterprise/2 . The important point is that yast2_network_setup ensures that NetworkManager is configured instead of wicked which I consider a very valid test approach as well as it is also a valid use case to change the network configuration and IMHO no other tests cover this. Of course it would make sense to add the test scenario for Laptop tests but that is not a useful base to build upon for now.

Needle yast2_network-is_applying-20180430 created -> https://openqa.opensuse.org/tests/666630 . Now failed on bsc#1079320 just like openSUSE TW.

#6 Updated by okurz about 2 years ago

  • Description updated (diff)
  • Status changed from In Progress to Workable
  • Assignee deleted (okurz)
  • Priority changed from High to Normal

#7 Updated by lnussel about 2 years ago

if yast2_network_setup switches to NM I'd call this a massive side effect. Suggest to rename the test to reflect what it actually does.

#8 Updated by SLindoMansilla about 2 years ago

  • Due date changed from 2018-06-05 to 2018-06-19

#9 Updated by okurz about 2 years ago

  • Status changed from Workable to Resolved
  • Assignee set to okurz

Actually I had the workaround implemented with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5072 already. I will track the bug anyway and we could remove some workaround whenever the bug would be fixed.

Also available in: Atom PDF