action #35524

[functional][u][sporadic][medium] test fails in snapper_cleanup because of "config is in use" - should we wait in subsequent snapper calls for the previous to finish?

Added by okurz almost 2 years ago. Updated over 1 year ago.

Status:ResolvedStart date:25/04/2018
Priority:LowDue date:
Assignee:zluo% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:medium
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_filesystem@64bit fails in
snapper_cleanup
with "config is in use". So it seems that snapper itself is still busy from the previous call and we did not wait long enough before calling the next command.

Reproducible

Fails since (at least) Build 20180424

Expected result

Last good: 20180423 (or more recent)

Suggestion

I think we just need to wait until we can call snapper again, e.g. try again after some waiting time until it finishes, e.g.

my $failed;
my $max_retries = 7;
for (1 .. $max_retries) {
    $failed = script_run 'snapper cleanup …';
    last unless $failed;
    report_info "Retry $_/$max_retries", 'Retrying …';
    sleep 1;
}
die "snapper cleanup did not finish successfully even after $max_retries tries" if $failed;

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 2 years ago

  • Due date changed from 22/05/2018 to 19/06/2018
  • Priority changed from Normal to Low
  • Target version changed from Milestone 16 to Milestone 17

last 9 jobs are fine so actually not that high prio.

#2 Updated by JERiveraMoya almost 2 years ago

  • Subject changed from [functional][u][sporadic] test fails in snapper_cleanup because of "config is in use" - should we wait in subsequent snapper calls for the previous to finish? to [functional][u][sporadic][medium] test fails in snapper_cleanup because of "config is in use" - should we wait in subsequent snapper calls for the previous to finish?
  • Difficulty set to medium

#3 Updated by mgriessmeier almost 2 years ago

  • Due date deleted (19/06/2018)

#4 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 17 to Milestone 19

#5 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 19 to Milestone 19

#6 Updated by okurz over 1 year ago

  • Target version changed from Milestone 19 to future

did see this in https://openqa.opensuse.org/tests/748992#step/snapper_cleanup/140 which is going from most recent https://openqa.opensuse.org/tests/763579 over the history 1/50 so valid still

#7 Updated by zluo over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and check.

#8 Updated by okurz over 1 year ago

Ok, please keep in mind that this is a low prio ticket within "future" so please limit the efforts

#9 Updated by zluo over 1 year ago

  • Status changed from In Progress to Resolved

http://e13.suse.de/tests/10947#next_previous shows no issue at all for 100 test runs.

on 3o we don't see this issue anymore:

https://openqa.opensuse.org/tests/latest?flavor=DVD&arch=x86_64&version=Tumbleweed&test=extra_tests_filesystem&distri=opensuse&machine=64bit#next_previous

I don't think cleanup created snapshots is a problem: assert_script_run("snapper cleanup number", 300); # cleanup created snapshots
300 is enough.

Also available in: Atom PDF