Project

General

Profile

action #34348

[functional][tools][u][xen] test is interrupted after vnc_two_passwords - connection to <openqaw5-xen.qa.suse.de> host is refused

Added by oorlov almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
michalnowak
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-04-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-extra_tests_on_gnome@svirt-xen-hvm is interrupted after
vnc_two_passwords

The issue occurs in each build since the tests were added. The error from autoinst-log:

[2018-03-19T21:54:14.0617 CET] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
DIE Error connecting to host : IO::Socket::INET: connect: Connection refused
at /usr/lib/os-autoinst/backend/baseclass.pm line 80.
backend::baseclass::die_handler('OpenQA::Exception::VNCSetupError=HASH(0x7abf808)') called at /usr/lib/perl5/vendor_perl/5.18.2/Exception/Class/Base.pm line 85
Exception::Class::Base::throw('OpenQA::Exception::VNCSetupError', 'error', 'Error connecting to host : IO::Socke...') called at /usr/lib/os-autoinst/consoles/VNC.pm line 151
consoles::VNC::login('consoles::VNC=HASH(0x70caf10)') called at /usr/lib/os-autoinst/consoles/VNC.pm line 842
consoles::VNC::send_update_request('consoles::VNC=HASH(0x70caf10)') called at /usr/lib/os-autoinst/consoles/vnc_base.pm line 82
consoles::vnc_base::request_screen_update('consoles::vnc_base=HASH(0x41cb968)', undef) called at /usr/lib/os-autoinst/backend/baseclass.pm line 587
backend::baseclass::bouncer('backend::svirt=HASH(0x521f848)', 'request_screen_update', undef) called at /usr/lib/os-autoinst/backend/baseclass.pm line 570
backend::baseclass::request_screen_update('backend::svirt=HASH(0x521f848)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 177
eval {...} called at /usr/lib/os-autoinst/backend/baseclass.pm line 156
backend::baseclass::run_capture_loop('backend::svirt=HASH(0x521f848)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 129
backend::baseclass::run('backend::svirt=HASH(0x521f848)', 5, 8) called at /usr/lib/os-autoinst/backend/driver.pm line 85
backend::driver::start('backend::driver=HASH(0x4d730e8)') called at /usr/lib/os-autoinst/backend/driver.pm line 48
backend::driver::new('backend::driver', 'svirt') called at /usr/bin/isotovideo line 211
main::init_backend() called at /usr/bin/isotovideo line 280

Reproducible

Fails since Build 358.1

Expected result

Last good: never

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #71236: job incompletes with auto_review:"backend died: Error connecting to VNC server <openqaw5-xen.qa.suse.de:5901>: IO::Socket::INET: connect: Connection refused"Rejected2020-09-11

History

#1 Updated by michalnowak almost 3 years ago

  • Category changed from Infrastructure to Bugs in existing tests
  • Status changed from New to Feedback
  • Assignee set to michalnowak

#2 Updated by okurz almost 3 years ago

  • Status changed from Feedback to Resolved

#3 Updated by okurz 6 months ago

  • Related to action #71236: job incompletes with auto_review:"backend died: Error connecting to VNC server <openqaw5-xen.qa.suse.de:5901>: IO::Socket::INET: connect: Connection refused" added

Also available in: Atom PDF