Project

General

Profile

action #34321

[functional][u][fast][medium] test fails in keymap_or_locale - potentially lost focus due to popup?

Added by lnussel about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Start date:
2018-04-05
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 24

Description

Observation

openQA test in scenario opensuse-15.0-DVD-x86_64-update_Leap_42.2_cryptlvm@uefi fails in
keymap_or_locale

Reproducible

Fails since (at least) Build 188.1

Expected result

Last good: 187.1 (or more recent)

Further details

Always latest result in this scenario: latest

Acceptance criteria

Analyse if currently active window looses focus due to notification pop up

History

#1 Updated by okurz about 2 years ago

  • Subject changed from test fails in keymap_or_locale to [functional][u][fast]test fails in keymap_or_locale - again!
  • Due date changed from 2018-04-12 to 2018-04-10
  • Target version set to Milestone 15

#2 Updated by mloviska about 2 years ago

Seems like the string was not typed in xterm because of lost focus. I guess, it is because of the notification popup which I have not noticed in the previous successful runs.
testapi::type_string(string='`1234567890-=~!@#$%&*()_+', max_interval=250, wait_screen_changes=0, wait_still_screen=0)

Do we encounter a product change ? Nevertheless I do not see any valid reason for this commotion and overreaction.

#3 Updated by okurz about 2 years ago

  • Subject changed from [functional][u][fast]test fails in keymap_or_locale - again! to [functional][u][fast]test fails in keymap_or_locale - potentially lost focus due to popup?
  • Priority changed from Normal to Urgent

#4 Updated by mloviska about 2 years ago

  • Subject changed from [functional][u][fast]test fails in keymap_or_locale - potentially lost focus due to popup? to [functional][u][fast][medium] test fails in keymap_or_locale - potentially lost focus due to popup?
  • Description updated (diff)
  • Status changed from New to Workable

#5 Updated by mloviska about 2 years ago

  • Description updated (diff)

#6 Updated by mloviska about 2 years ago

  • Difficulty set to medium

#7 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

#8 Updated by mloviska about 2 years ago

9/10 runs are passing fine opensuse-15.0-DVD-x86_64-Build191.1-update_Leap_42.2_cryptlvm@uefi. But maybe we could exclude the notification area from a needle,wdyt ? http://dhcp228.suse.cz/tests/1564#step/keymap_or_locale/1

#10 Updated by mloviska about 2 years ago

  • Status changed from Workable to Feedback

#11 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

waiting for merge, moving to S16

#12 Updated by mloviska about 2 years ago

Turning desktop notification off by issuing "gsettings set org.gnome.desktop.notifications show-banners false" does not really affect this particular popup ( maybe popups in general ?! ). Turning off over here does not prevent the notification to appear over here later on anyway. Any other ideas how to disable this particular notification are very much appreciated!

#14 Updated by okurz about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF