Project

General

Profile

action #33979

[sle][functional][y][hyperv][easy] test fails in installation_overview - needle autoyast_removed is not matching

Added by zluo about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-28
Due date:
2018-05-22
% Done:

0%

Estimated time:
Difficulty:
Duration: 40

Description

Compared with last successful run, it looks that needle autoyast_removed doesn't match anymore in current test run.

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-textmode@svirt-hyperv-uefi fails in
installation_overview

Reproducible

Fails since (at least) Build 535.1 (current job)

Expected result

Last good: 533.2 (or more recent)

Suggestions

  • cleanup wrongly created needles and create correct ones - better done in pair-needling - according to #33979#note-2

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional] test fails in installation_overview - needle autoyast_removed is not matching to [sle][functional][y][hyperv][fast] test fails in installation_overview - needle autoyast_removed is not matching
  • Due date set to 2018-04-10
  • Status changed from New to Workable
  • Assignee set to riafarov
  • Target version set to Milestone 15

riafarov please investigate together with zluo why we should miss an "autoyast" needle in textmode@hyperv

#2 Updated by riafarov about 2 years ago

  • Assignee changed from riafarov to okurz

There are tons of wrongly created needles, so we don't check was was intended here. See last good: https://openqa.suse.de/tests/1571526#step/installation_overview/4

So we can make the test work by creating yet another wrong needle, or do this check (not sure if it makes sense in each scenario if at all).
It's quite some work to make it right, so I suggest either raise the priority or move to the next sprint as we already have many tickets for current sprint.

#3 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][y][hyperv][fast] test fails in installation_overview - needle autoyast_removed is not matching to [sle][functional][y][hyperv] test fails in installation_overview - needle autoyast_removed is not matching
  • Description updated (diff)
  • Due date changed from 2018-04-10 to 2018-04-24
  • Assignee deleted (okurz)
  • Priority changed from Normal to High

Well, I do not understand where the issue comes from that tests fail now but ok, moved to next sprint.

#4 Updated by okurz about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-22
  • Target version changed from Milestone 15 to Milestone 16

S15+S16 full.

#5 Updated by riafarov about 2 years ago

  • Assignee set to riafarov

#6 Updated by riafarov about 2 years ago

  • Status changed from Workable to Resolved

In text mode we use release notes button to navigate to the overview
area and then scroll. However, on hyperv as we have problems with
performance, we still had focus on release notes button.
Failure happened only ones, but can potentially break.

https://openqa.suse.de/tests/1677187

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4994
Test didn't fail for more than a month.

#7 Updated by riafarov about 2 years ago

  • Subject changed from [sle][functional][y][hyperv] test fails in installation_overview - needle autoyast_removed is not matching to [sle][functional][y][hyperv][easy] test fails in installation_overview - needle autoyast_removed is not matching

Also available in: Atom PDF