Project

General

Profile

action #33517

[functional][y][yast][sporadic][medium] yast2_control_center: possible conflict with PackageKit doing background refresh

Added by dimstar about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-20
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 36

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_gui@64bit fails in
yast2_control_center

Reproducible

Fails since (at least) Build 20180314

Expected result

Last good: 20180313 (or more recent)

Suggestions

Call pkcon_quit within test module.

As an alternative, we can explore if pressing yes is stable enough to fix in the test. (First option is still preferable)

Further details

Always latest result in this scenario: latest

either we explicitly terminate PK before hand or we ensure the pk refresh is completed (the test sometimes passes, most of the times fails).

History

#1 Updated by okurz about 2 years ago

  • Subject changed from yast2_control_center: possible conflict with PackageKit doing background refresh to [functional][y][yast]yast2_control_center: possible conflict with PackageKit doing background refresh
  • Target version set to Milestone 16

#2 Updated by okurz about 2 years ago

  • Due date set to 2018-04-10
  • Priority changed from Normal to Urgent
  • Target version changed from Milestone 16 to Milestone 15

failing reproducibly every time since the mentioned build

#3 Updated by dimstar about 2 years ago

failing reproducibly every time since the mentioned build

not really - whenever the PK conflict does not show up (and I see it) I can create one or two more needles. The failure always happens to be in the same module, but it is not always the exact same error

e.g. https://openqa.opensuse.org/tests/643136#step/yast2_control_center/20 failed on missing needles for the printer config

#4 Updated by riafarov about 2 years ago

  • Subject changed from [functional][y][yast]yast2_control_center: possible conflict with PackageKit doing background refresh to [functional][y][yast][sporadic] yast2_control_center: possible conflict with PackageKit doing background refresh
  • Description updated (diff)
  • Status changed from New to Workable

I see, in cases like these feel free to add the subject keyword "[sporadic]" so that no one states: "One job did not fail, is it solved?" ;)

#5 Updated by cwh about 2 years ago

  • Assignee set to cwh

So unconditionally calling pkcon quit before starting sw_single should maybe solve that problem, shouldn't it?

#6 Updated by okurz about 2 years ago

  • Subject changed from [functional][y][yast][sporadic] yast2_control_center: possible conflict with PackageKit doing background refresh to [functional][y][yast][sporadic][medium] yast2_control_center: possible conflict with PackageKit doing background refresh

yes

#7 Updated by cwh about 2 years ago

  • Status changed from Workable to In Progress

#8 Updated by cwh about 2 years ago

  • Difficulty set to medium

#9 Updated by cwh about 2 years ago

My first try to solve this by a simple "pkcon quit" was not successful:
http://boltzmann.suse.de/tests/43#step/yast2_control_center/2

Using this way we don't know how long PackageKit will take until it actually quits. So maybe it is better to go for the button-clicking solution.

#10 Updated by okurz about 2 years ago

yes, I also do not have any better plan now. Should be ok to have a multi-tag assert_screen with if match_has_tag. https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/x11/kontact.pm can provide an example.

#11 Updated by cwh about 2 years ago

  • Status changed from In Progress to Feedback

The clicking approach works – using a wisely selected needle even with all the repeated dialogs that ask to try to quit again.
http://boltzmann.suse.de/tests/55

Here the PR for the code:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4775

and the needle:
https://github.com/os-autoinst/os-autoinst-needles-opensuse/pull/349

#12 Updated by cwh about 2 years ago

While continuing to update needles for that test I found two more cases when PackageKit can sporadically block that test:

  • online-update
  • online-repositories

I keep fixing them as they go. I guess I got them all, now.
http://boltzmann.suse.de/tests/65

#13 Updated by riafarov about 2 years ago

Initial problem resolved.

#14 Updated by riafarov about 2 years ago

  • Status changed from Feedback to Resolved

#15 Updated by cwh about 2 years ago

  • Status changed from Resolved to Feedback

#16 Updated by okurz about 2 years ago

  • Due date changed from 2018-04-10 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

The latest test run seems to be fine: https://openqa.opensuse.org/tests/662672

cwh do you think we should resolve this one or do you think you want to gather more statistics?

#17 Updated by cwh about 2 years ago

  • Status changed from Feedback to Resolved

Should be enough.

Also available in: Atom PDF