Project

General

Profile

action #33514

[tools] Use of uninitialized value $status in right bitshift (>>)

Added by EDiGiacinto over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2018-03-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Test are failing sporadically on this (as for now SLE SP3, Leap 42.2 and Leap 42.3):

[  120s] 
[  120s] Use of uninitialized value $status in right bitshift (>>) at ../osutils.pm line 126.
[  120s]     not ok 3 - command failed and calls die
[  120s]     #   Failed test 'command failed and calls die'
[  120s]     #   at ./13-osutils.t line 159.
[  120s]     #                   ''
[  120s]     #     doesn't match '(?^u:runcmd failed with exit code \d+)'
[  120s]     1..3
[  120s]     # Looks like you failed 1 test of 3.
[  120s] not ok 6 - runcmd
[  120s] #   Failed test 'runcmd'
[  120s] #   at ./13-osutils.t line 160.
[  120s] 1..6

In another build log:

[  839s] Use of uninitialized value $status in right bitshift (>>) at ../osutils.pm line 126.
[  839s]     not ok 3 - command failed and calls die
[  839s]     #   Failed test 'command failed and calls die'
[  839s]     #   at ./13-osutils.t line 159.
[  839s]     #                   ''
[  839s]     #     doesn't match '(?^u:runcmd failed with exit code \d+)'
[  839s]     1..3
[  839s]     # Looks like you failed 1 test of 3.
[  839s] not ok 6 - runcmd

Possibly caused by: https://github.com/os-autoinst/os-autoinst/pull/898


Related issues

Related to openQA Project - action #37580: "Use of uninitialized value $status in right bitshift (>>) at /usr/lib/os-autoinst/osutils.pm line 128." on aarch64Resolved2018-06-21

History

#1 Updated by EDiGiacinto over 2 years ago

  • Related to action #37580: "Use of uninitialized value $status in right bitshift (>>) at /usr/lib/os-autoinst/osutils.pm line 128." on aarch64 added

#2 Updated by szarate about 2 years ago

Yet again :( sle12 sp3

[ 573s] Use of uninitialized value $status in right bitshift (>>) at ../osutils.pm line 118.
[ 573s] not ok 3 - command failed and calls die
[ 573s] # Failed test 'command failed and calls die'
[ 573s] # at ./13-osutils.t line 167.
[ 573s] # ''
[ 573s] # doesn't match '(?u:runcmd failed with exit code \d+)'
[ 573s] 1..3
[ 574s] # Looks like you failed 1 test of 3.
[ 574s] not ok 6 - runcmd
[ 574s] # Failed test 'runcmd'
[ 574s] # at ./13-osutils.t line 168.
[ 574s] # Subtest: attempt

#3 Updated by szarate about 2 years ago

And now it happens on tests:

[2018-07-27T08:26:02.0670 UTC] [debug] runcmd pid 71623 returned 71623
[2018-07-27T08:26:02.0672 UTC] [debug] running /usr/bin/qemu-img info --output=json /usr/share/qemu/aavmf-aarch64-code.bin
Use of uninitialized value $status in right bitshift (>>) at /usr/lib/os-autoinst/osutils.pm line 118.
[2018-07-27T08:26:02.0715 UTC] [debug] running /usr/bin/qemu-img info --output=json /usr/share/qemu/aavmf-aarch64-vars.bin
[2018-07-27T08:26:03.0222 UTC] [info] Collected unknown process with pid 71626 and exit status: 0

#4 Updated by szarate about 2 years ago

  • Subject changed from [tools] os-autoinst fails to build on obs to [tools] Use of uninitialized value $status in right bitshift (>>)
  • Priority changed from Normal to High

Also on OSD: setting prio to high, since I've seen it today at least 4 times

And Can also reproduce locally

Use of uninitialized value $status in right bitshift (>>) at /usr/lib/os-autoinst/osutils.pm line 118.
[2018-07-26T18:21:43.0390 CEST] [debug] running /usr/bin/qemu-img create -f qcow2 -b /var/lib/openqa/pool/1/raid/cd0-overlay4 /var/lib/openqa/pool/1/raid/cd0-overlay5 4068399104

#5 Updated by szarate about 2 years ago

  • Priority changed from High to Urgent

I'm raising this a bit, it's getting kind of annoying :) I know @mudler is working on this though.

https://openqa.suse.de/tests/1883862/file/autoinst-log.txt

#6 Updated by EDiGiacinto about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to EDiGiacinto

Working on it

#7 Updated by EDiGiacinto about 2 years ago

  • Status changed from In Progress to Feedback
  • Target version set to Current Sprint

#8 Updated by szarate about 2 years ago

  • Status changed from Feedback to Resolved

I think we're done here

#9 Updated by coolo about 2 years ago

  • Target version changed from Current Sprint to Done

Also available in: Atom PDF