Project

General

Profile

action #33283

[opensuse][functional][u][sporadic][medium] test fails in kontact - typing string loosing characters

Added by zluo about 2 years ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-14
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 40

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde-wayland@64bit_virtio fails in
kontact

Reproducible

Fails since (at least) Build 20170825

Expected result

Corresponding testcase on x11

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #30805: [functional][opensuse][leap][medium][u] first test after reboot fails in krunner, potential system overload (was: test fails in inkscape - typing too fast?)Resolved2018-01-252018-08-14

Has duplicate openQA Tests - action #34363: test fails in kontactRejected2018-04-052018-04-13

History

#1 Updated by okurz about 2 years ago

  • Related to action #30805: [functional][opensuse][leap][medium][u] first test after reboot fails in krunner, potential system overload (was: test fails in inkscape - typing too fast?) added

#2 Updated by okurz about 2 years ago

  • Target version set to Milestone 16

something to look for after #30805

#3 Updated by zluo about 2 years ago

compared with successful run: https://openqa.opensuse.org/tests/609894#step/kontact/13

It is a problem with mistyping. I check the history and found this problem happened many times in the past.

#4 Updated by okurz about 2 years ago

#5 Updated by okurz about 2 years ago

  • Subject changed from [opensuse tw][functional] test fails in kontact - typing string loosing characters to [opensuse][functional][u] test fails in kontact - typing string loosing characters
  • Due date set to 2018-05-08
  • Priority changed from Normal to High

Latest report from lnussel about Leap 15.0:

Observation

openQA test in scenario opensuse-15.0-DVD-x86_64-kde-wayland@64bit_virtio-2G fails in
kontact

looking at the video x11_start_program seems to be unreliable with wayland. it mistypes the command and starts random progams. no idea why it always hits the kontact test though :)

Reproducible

Fails since (at least) Build 156.1

Further details

Always latest result in this scenario: latest

#6 Updated by mgriessmeier about 2 years ago

  • Subject changed from [opensuse][functional][u] test fails in kontact - typing string loosing characters to [opensuse][functional][u][medium] test fails in kontact - typing string loosing characters
  • Description updated (diff)
  • Status changed from New to Workable

#7 Updated by cwh about 2 years ago

  • Difficulty set to medium

#8 Updated by zluo about 2 years ago

  • Assignee set to zluo

take over...

#9 Updated by zluo about 2 years ago

  • Status changed from Workable to In Progress

#10 Updated by JERiveraMoya about 2 years ago

I found this one in case you could have buffer on this ticket, I guess at the end we need to close that windows that is avoiding to match needles: #35589. It is not related with the typing and I think is also present in tw.

#11 Updated by zluo about 2 years ago

Yesterday it has problem with needle match on osd:
https://openqa.opensuse.org/tests/662767

but the problem with typing string doesn't happen anymore:

https://openqa.opensuse.org/tests/663701

and my local test run shows correct result as well:
http://e13.suse.de/tests/2172

#12 Updated by zluo about 2 years ago

will re-run the tests for 50 times and see if it still has problem or not.

#13 Updated by zluo about 2 years ago

till now with a lot of test run, I can say this issue is not reproducible.

#15 Updated by zluo about 2 years ago

force_cron_run from another test on o3 shows good result:

https://openqa.opensuse.org/tests/664925#step/force_cron_run

#17 Updated by zluo about 2 years ago

#19 Updated by zluo about 2 years ago

  • Status changed from In Progress to Resolved

I don't see this problem anymore by re-tests o3 and my local server. Set is as resolved.

#20 Updated by okurz about 2 years ago

  • Subject changed from [opensuse][functional][u][medium] test fails in kontact - typing string loosing characters to [opensuse][functional][u][sporadic][medium] test fails in kontact - typing string loosing characters
  • Status changed from Resolved to In Progress

I don't know how you checked but checking the latest TW test immediately shows a failure in kontact: https://openqa.opensuse.org/tests/667728 and also the history shows that kontact fails like near every time except for the cases that the scenario already aborts in before, e.g. on oocalc.

#21 Updated by zluo about 2 years ago

this is a different issue which i mentioned already:

https://bugzilla.opensuse.org/show_bug.cgi?id=1055830

#22 Updated by zluo about 2 years ago

again, a lot of test runs didn't show this issue on my local server

http://e13.suse.de/tests/2229

and test run on osd:

https://openqa.opensuse.org/tests/664926#step/kontact

#23 Updated by zluo about 2 years ago

  • Status changed from In Progress to Resolved

#24 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: kde-wayland@64bit_virtio
https://openqa.opensuse.org/tests/1005564

Also available in: Atom PDF