Project

General

Profile

action #32596

[functional]systemd networkd_init verifies presence of /var/lib/machines?

Added by dimstar almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-01
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-systemd-networkd@64bit fails in
networkd_init

Reproducible

Fails since (at least) Build 20180228

This fails because /var/lib/machines is no longer bundled by the main systemd package but is now part of systemd-containerd.
All this though should not matter, as networkd does not need to access this directory.

History

#1 Updated by dimstar almost 5 years ago

dimstar wrote:

This fails because /var/lib/machines is no longer bundled by the main systemd package but is now part of systemd-containerd.

should be systemd-container

#2 Updated by okurz almost 5 years ago

  • Subject changed from systemd networkd_init verifies presence of /var/lib/machines? to [functional]systemd networkd_init verifies presence of /var/lib/machines?
  • Assignee set to dheidler
  • Target version set to Milestone 14

dheidler can you take a look?

#3 Updated by dheidler almost 5 years ago

dimstar wrote:

All this though should not matter, as networkd does not need to access this directory.

Networkd doesn't, but the my testsuite does.
It is using systemd-nspawn containers and networkd is run inside of the containers.
The containers need /var/lib/machines.

#5 Updated by dheidler almost 5 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 80

#6 Updated by dheidler almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Merged

#7 Updated by okurz almost 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: systemd-networkd
https://openqa.opensuse.org/tests/644110

Also available in: Atom PDF