Project

General

Profile

action #32332

action #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards

[opensuse][functional][y][fast] repo bleed affecting gnuhealth installation

Added by dimstar about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-02-27
Due date:
2018-04-10
% Done:

0%

Estimated time:
Difficulty:
Duration: 31

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-gnuhealth@64bit fails in
gnuhealth_install

Reproducible

Fails since (at least) Build 20180225

From what I see, this test actually tries to access download.opensuse.org and does have 'old' information about available packages, in this specific case especially, it wants to do:

2018-02-27 03:08:01 susetest(2546) [zypp] SATResolver.cc(problems):1323 downgrade of python3-cffi-1.11.4-1.1.x86_64 to python3-cffi-1.11.2-2.1.x86_64
2018-02-27 03:08:01 susetest(2546) [zypp] SATResolver.cc(problems):1323 downgrade of python3-cryptography-2.1.4-4.2.x86_64 to python3-cryptography-2.1.4-4.1.x86_64

Since python3-cffi was updated to the new version in snapshot 0225 - and the suggestion is to downgrade to a version no longer present in this snapshot, there is only the option that it must read it from download.o.o/tumbleweed/repo

History

#1 Updated by okurz about 2 years ago

  • Is duplicate of action #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards added

#2 Updated by okurz about 2 years ago

  • Subject changed from repo bleed affecting gnuhealth installation to [opensuse][functional]repo bleed affecting gnuhealth installation
  • Due date set to 2018-04-10
  • Target version set to Milestone 16

duplicates #17436, right?

#3 Updated by dimstar about 2 years ago

I see #17436 as a parent issue, with this one being a specific one, probably quite easy to fix by correcting the repo list in the create_hdd test run.

#4 Updated by okurz about 2 years ago

  • Is duplicate of deleted (action #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards)

#5 Updated by okurz about 2 years ago

  • Blocked by action #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards added

#6 Updated by okurz about 2 years ago

  • Blocked by deleted (action #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards)

#7 Updated by okurz about 2 years ago

  • Due date deleted (2018-04-10)
  • Status changed from New to Blocked
  • Assignee set to riafarov
  • Parent task set to #17436

#8 Updated by riafarov about 2 years ago

  • Subject changed from [opensuse][functional]repo bleed affecting gnuhealth installation to [opensuse][functional][y][fast] repo bleed affecting gnuhealth installation
  • Due date set to 2018-04-10
  • Status changed from Blocked to Resolved

https://openqa.opensuse.org/tests/652998# uses image without download.opensuse.org repos.
Resolved indirectly.

Also available in: Atom PDF