Project

General

Profile

action #30823

[sle][functional][tools][iscsi][hard] test is stuck in linuxrc asking if dhcp should be used - since worker upgrade/qemu/os-autoinst?

Added by okurz over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Infrastructure
Start date:
2018-01-25
Due date:
2018-03-27
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-x86_64-iscsi_ibft@64bit fails in
welcome
with a linuxrc popup about "Automatic configuration via DHCP?".

Reproducible

Fails since (at least) Build 0164 or "some days".
This is reproducible in SLE15 also since the same time: https://openqa.suse.de/tests/1417099#step/welcome/3
as well as on lord.arch where I am also running openSUSE Leap 42.3 with qemu 2.9.1 since some time already.

Expected result

Last good: 0161 (or more recent)

Problem

Comparing the logfiles from the SLE15 first bad with SLE15 last good I see as differences especially the following

-QEMU emulator version 2.9.1(openSUSE Leap 42.3)
+QEMU emulator version 2.6.2 (openSUSE Leap 42.2), Copyright (c) 2003-2008 Fabrice Bellard
-starting: /usr/bin/qemu-system-x86_64 … -append 'dhcp && sanhook iscsi:10.160.0.243::3260:1:iqn.2016-02.openqa.de:for.openqa' …
+starting: /usr/bin/qemu-system-x86_64 … -append dhcp && sanhook iscsi:10.160.0.243::3260:1:iqn.2016-02.openqa.de:for.openqa' …

so as expected we run the newer qemu version now but also the single tick which seems to have appeared now. However, on lord.arch I have

QEMU emulator version 2.9.1(openSUSE Leap 42.3)
starting: /usr/bin/qemu-kvm … -append dhcp && sanhook iscsi:::3260:1:iqn.2016-02.openqa.de:for.openqa …

so no IP-address for iscsi and no single tick. The missing IP-address is another issue though, WORKER_CLASS is not checked for and was just empty for me. Added that now locally. Result: same as on osd now: http://lord.arch/tests/397 . Failed with same dialog about dhcp, iscsi ip config is same but no single tick around arguments which should therefore not be the problem. I suspect the qemu version makes a difference then.

Further details

Always latest result in this scenario: latest


Related issues

Is duplicate of openQA Tests - action #23554: [sle][functional][tools][yast][y][hard] test fails in iscsi_configuration because of missing updated needle iscsi-ibft / missing iscsi server on osd?Resolved2017-08-232018-05-22

Blocks openQA Tests - action #30685: [sle][functional][sle12 sp4][u] test fails in firefox - firefox_readerview_window doesn't matchResolved2018-01-232018-06-19

History

#1 Updated by okurz over 4 years ago

  • Blocks action #30685: [sle][functional][sle12 sp4][u] test fails in firefox - firefox_readerview_window doesn't match added

#2 Updated by okurz over 4 years ago

  • Status changed from New to In Progress

#3 Updated by okurz over 4 years ago

  • Target version set to Milestone 14

#4 Updated by okurz over 4 years ago

  • Related to action #23554: [sle][functional][tools][yast][y][hard] test fails in iscsi_configuration because of missing updated needle iscsi-ibft / missing iscsi server on osd? added

#5 Updated by okurz over 4 years ago

  • Subject changed from [sle][functional][tools][iscsi] test is stuck in linuxrc asking if dhcp should be used - since worker upgrade/qemu/os-autoinst? to [sle][functional][tools][iscsi][hard] test is stuck in linuxrc asking if dhcp should be used - since worker upgrade/qemu/os-autoinst?
  • Due date set to 2018-03-27
  • Status changed from In Progress to Blocked
  • Assignee set to okurz
  • Target version changed from Milestone 14 to Milestone 15

workaround merged, production instance job triggered and passed this step so the workaround works, see https://openqa.suse.de/tests/1449277#step/iscsi_configuration/4 but now stuck in #23554 which we should work on first to ensure it's not the same problem.

#6 Updated by riafarov over 4 years ago

  • Related to deleted (action #23554: [sle][functional][tools][yast][y][hard] test fails in iscsi_configuration because of missing updated needle iscsi-ibft / missing iscsi server on osd?)

#7 Updated by riafarov over 4 years ago

  • Is duplicate of action #23554: [sle][functional][tools][yast][y][hard] test fails in iscsi_configuration because of missing updated needle iscsi-ibft / missing iscsi server on osd? added

#8 Updated by riafarov over 4 years ago

  • Status changed from Blocked to Resolved

This screen is result of the problem we have in https://progress.opensuse.org/issues/23554 resolving as duplicate.

Also available in: Atom PDF