Project

General

Profile

action #28573

coordination #28949: [sle][functional][opensuse][epic] Improve test coverage of partitioning_raid

[sle][functional][hard] Add bios boot partition in RAID test

Added by riafarov almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Enhancement to existing tests
Start date:
2017-11-29
Due date:
2017-12-19
% Done:

0%

Estimated time:
Difficulty:

Description

As per comment in https://bugzilla.suse.com/show_bug.cgi?id=1063957 for storage ng to fix an issue we also need to adjust test as it's expected behavior now.

This has high priority as is blocking staging.

Acceptance criteria

  • AC1: RAID test pass

Tasks

History

#1 Updated by okurz almost 4 years ago

  • Description updated (diff)

riafarov: What you wrote as ACs are none of that kind. These are "tasks" or "suggestions". IIUC the AC is "Bug is verified fixed".

Can we see a verification done by the yast team on their openQA instance first?

#2 Updated by riafarov almost 4 years ago

  • Description updated (diff)

okurz I can explain you the situation in details in person, as it contains personal data in it. I've updated AC. We cannot see verification run because test code requires changes.

#3 Updated by okurz almost 4 years ago

  • Due date set to 2017-12-19
  • Priority changed from Normal to High
  • Target version set to Milestone 12

let's plan for the next sprint then

#4 Updated by riafarov almost 4 years ago

  • Status changed from New to Feedback

Code changes here: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4009
Waiting for the build with the fix before merging

#5 Updated by SLindoMansilla almost 4 years ago

  • Parent task set to #28949

#6 Updated by riafarov almost 4 years ago

  • Subject changed from [sle][functional] Add bios boot partition in RAID test to [sle][functional][hard] Add bios boot partition in RAID test

#7 Updated by riafarov almost 4 years ago

  • Status changed from Feedback to Resolved

#8 Updated by SLindoMansilla almost 4 years ago

I think something went wrong here: https://openqa.suse.de/tests/1333716#step/partitioning_raid/57

  • A BIOS Boot partition is created for each hard disk,
  • but it should only be one, so on SLE 12-SP3 there was one RAID partition on each disk that later were used with raid0 as boot partition.

Also available in: Atom PDF