Project

General

Profile

action #28385

"worker status timer calculation" sometimes fails, not sure why

Added by AdamWill over 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2017-11-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

I've just tried building current git openQA four times for Fedora. On the first run, all the tests passed, but the build failed because I had forgotten to add the resource-allocator service files to the %files spec section. After fixing that, I tried building it three more times, but each time, the build failed because one of the large number of checks run in the "worker status timer calculation" subtest in 24-worker.t failed, always the same one:

not ok 229 - timer between instances 30 and 200 is different in a population of 270 ( 36 != 36 )

on the build where the tests passed, this was the result for that check:

ok 229 - timer between instances 30 and 200 is different in a population of 270 ( 38 != 36 )

I have no idea what could possibly be causing the problem (or what the hell this test is even checking, since as is traditional for openQA, the entire very complex test has about three comments in it and does not make what it's doing clear at all.)

History

#1 Updated by okurz about 2 years ago

  • Category set to Concrete Bugs

#2 Updated by okurz about 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz
  • Priority changed from Normal to Low
  • Target version set to future

AFAIK we run the test on every commit in git master on an openSUSE Leap base as well as in OBS against Tumbleweed without problems. You haven't reported about further problems so I assume this doesn't impact you much, assuming irrelevant as of now

#3 Updated by AdamWill about 1 year ago

yeah, it seems I don't have that test disabled at present and I don't recall seeing a build fail on it lately, so it must have got fixed somehow.

Also available in: Atom PDF