Project

General

Profile

tickets #28343

wrong links

Added by jorge.plaza.10@gmail.com almost 4 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Software portal
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

History

#1 Updated by pjessen almost 4 years ago

  • Private changed from Yes to No

Hello Jorge

when I copied and pasted a link into my browser, I was automatically redirected to the correct location.
However, with addrepo it looks like this:

zypper addrepo 'https://download.opensuse.org/repositories/Virtualization:containers/openSUSE_Leap_42.3/Virtualization:containers.repo'
Download (curl) error for 'https://download.opensuse.org/repositories/Virtualization:containers/openSUSE_Leap_42.3/Virtualization:containers.repo':
Error code: Bad URL
Error message: Protocol http not supported or disabled in libcurl

Abort, retry, ignore? a/r/i/...? shows all options:

Also, most mirrors don't support https, so I tried this instead:

zypper addrepo 'http://download.opensuse.org/repositories/Virtualization:containers/openSUSE_Leap_42.3/Virtualization:containers.repo'
Adding repository 'Virtualization:containers (openSUSE_Leap_42.3)' ...................................................................................................................................................................[done]
Repository 'Virtualization:containers (openSUSE_Leap_42.3)' successfully added

URI : http://download.opensuse.org/repositories/Virtualization:/containers/openSUSE_Leap_42.3/
Enabled : Yes
GPG Check : Yes
Autorefresh : No
Priority : 99 (default priority)

zypper refresh
Retrieving repository 'Virtualization:containers (openSUSE_Leap_42.3)' metadata ---------------------------------------------------------------------------------------------------------------------------------------------------------[]

New repository or package signing key received:

Repository: Virtualization:containers (openSUSE_Leap_42.3)
Key Name: Virtualization OBS Project Virtualization@build.opensuse.org
Key Fingerprint: 55A0B34D 49501BB7 CA474F5A A193FBB5 72174FC2
Key Created: Thu 29 Oct 2015 02:57:46 CET
Key Expires: Sat 06 Jan 2018 02:57:46 CET (expires in 42 days)
Rpm Name: gpg-pubkey-72174fc2-56317d1a

It seems to work, except https doesn't work.

#2 Updated by tampakrap over 3 years ago

  • Category set to Software portal
  • Assignee set to ancorgs

#3 Updated by tampakrap almost 3 years ago

  • Status changed from New to Rejected

If the issue is still valid, please report it to https://github.com/openSUSE/software-o-o/issues

Also available in: Atom PDF