Project

General

Profile

action #27994

[qam][expedite][sprint 201711.2] test fails in test setup in bmwqemu.pm

Added by pcervinka about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-11-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA sle-12-SP3-Server-DVD-Updates-x86_64-Build20171121-1-mau-qa_acceptance_process_stress@64bit fails in
setup

Reproducible

Happens randomly for other testsuites as well:
https://openqa.suse.de/tests/1258348/file/autoinst-log.txt
https://openqa.suse.de/tests/1258278/file/autoinst-log.txt
https://openqa.suse.de/tests/1258388/file/autoinst-log.txt

History

#1 Updated by pcervinka about 4 years ago

+++ setup notes +++
start time: 2017-11-21 01:56:27
running on openqaworker3:12 (Linux 4.7.5-2.g02c4d35-default #1 SMP PREEMPT Mon Sep 26 08:11:45 UTC 2016 (02c4d35) x86_64)
Downloading SLES-12-SP3-x86_64-mru-install-minimal-with-addons-Build20171121-1.qcow2 from openqa.suse.de/tests/1258356/asset/hdd/SLES-12-SP3-x86_64-mru-install-minimal-with-addons-Build20171121-1.qcow2
CACHE: Content has not changed, not downloading the /var/lib/openqa/cache/SLES-12-SP3-x86_64-mru-install-minimal-with-addons-Build20171121-1.qcow2 but updating last use
Downloading SLE-12-SP3-Server-DVD-x86_64-GM-DVD1.iso from openqa.suse.de/tests/1258356/asset/iso/SLE-12-SP3-Server-DVD-x86_64-GM-DVD1.iso
CACHE: Content has not changed, not downloading the /var/lib/openqa/cache/SLE-12-SP3-Server-DVD-x86_64-GM-DVD1.iso but updating last use
+++ worker notes +++
start time: 2017-11-21 01:56:29
running on openqaworker3:12 (Linux 4.7.5-2.g02c4d35-default #1 SMP PREEMPT Mon Sep 26 08:11:45 UTC 2016 (02c4d35) x86_64)
cannot remove directory for testresults/.thumbs: Directory not empty at /usr/lib/os-autoinst/bmwqemu.pm line 111.
cannot remove directory for testresults: Directory not empty at /usr/lib/os-autoinst/bmwqemu.pm line 111.
Can't mkdir('testresults'): File exists at /usr/lib/os-autoinst/bmwqemu.pm line 112
12217: EXIT 1
+++ worker notes +++
end time: 2017-11-21 01:56:31
result: died
uploading vars.json
uploading autoinst-log.txt

#2 Updated by pcervinka about 4 years ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Status changed from New to In Progress
  • Assignee set to nicksinger

Filesystem issue on openqaworker3:12.
nsinger powered off the machine:
11:52:13 nsinger | FYI: I've completely powered off the machine to avoid further damage in the FS. Will sync with the tools time how we want to proceed

#3 Updated by nicksinger about 4 years ago

  • Category changed from Infrastructure to Bugs in existing tests
  • Assignee deleted (nicksinger)

I've powered down the machine in question (openqaworker3) for now because it showed FS errors on the NVMe partition.
I'll talk to @foursixnine how to continue here.

#4 Updated by szarate about 4 years ago

  • Subject changed from [qam] test fails in test setup in bmwqemu.pm to [qam][expedite][sprint 201711.2] test fails in test setup in bmwqemu.pm
  • Status changed from In Progress to Resolved
  • Assignee set to szarate

Problem solved, the machine has errors in it's filesystem, but since it was only on the nvme which is mounted on /var/lib/openqa/pool, a simple reboot + mkfs.ext2 did the trick

Also available in: Atom PDF