Project

General

Profile

action #26908

[qam] test fails in firefox_urlsprotocols

Added by osukup over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-10-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

jekyll.rb is now automatically redirected to https protocol, so not valid for test of "http"

openQA test in scenario sle-12-SP3-Desktop-DVD-Updates-x86_64-qam-regression-firefox@64bit fails in
firefox_urlsprotocols

Reproducible

Fails since (at least) Build 20170804-1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-regression-firefox
https://openqa.suse.de/tests/1241649

#2 Updated by vsvecova over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to vsvecova

#3 Updated by vsvecova over 4 years ago

(from pcervinka's email):

It will be harder and harder to find pages with http only. Almost all
known/usable sites redirect from http to https.

What about keep it as it is? Test will use http, server redirects to
https. I think this can be used as valid (because http works and resultof working http is redirect to https)

Yeah, I hear you, with the search engine companies and other big players of the web industry requiring and/or giving advantage to secure sites, it will be more and more rare to find a suitable http website for this test.

Personally, however, I believe that the tests should be straightforward and semantic, and I'm not that keen on the idea of establishing that the http protocol works properly on the grounds that it redirects correctly to https (on this particular website).

I have found out that BBC is planning to stick to the unsecured http protocol in their news archive, at least for the foreseeable future, as explained in their official blog: http://www.bbc.co.uk/blogs/internet/entries/f6f50d1f-a879-4999-bc6d-6634a71e2e60

"Sites and content we consider ‘archival’ that involve no signing in or personalisation, such as the News Online archive on news.bbc.co.uk, will remain HTTP-only. This is due to the cost we’d incur processing tens of millions of old files to rewrite internal links to HTTPS when balanced against the benefit."

So maybe the BBC news website could work for now.

On the other hand, I like your suggestion in the sense that we could consider extending this test module with the http>https redirection as a case on its own right, since it is a very common practice on the web for a lot of websites.

#4 Updated by coolo over 4 years ago

I suggest to switch to http://eu.httpbin.org/html - it's a site explicitly for testing http. It will not switch to https

Also available in: Atom PDF