Project

General

Profile

action #25444

action #19926: [qam] test fails in firefox - new tutorial window covering the matching area

[opensuse]firefox_java: define needles for 'firefox_clean'

Added by dimstar about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-09-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Based on test run

https://openqa.opensuse.org/tests/488943#step/firefox_java/30

I am not sure how 'firefox clean' is supposed to work/match; the are the needle contains is 'changing depending on content shown on screen'; I've seen various changes already:

  • Just the 'i and lock', followed by a vertical bar (this was the original needle I had seen)
  • The i, the lock sign, then then 'verified company' name from SSL (as the vert bar was not seen, this asked for a 'smaller' needle, without the vertical bar
  • From firefox_java now, this also includes a 'plugin symbol' - It starts to feel 'weird' to call it 'firefox clean', and it would be good to define what is supposed to be seen here

History

#1 Updated by vsvecova about 5 years ago

Hi dimstar,

The "clean" in the firefox_clean needle basically means "without any unhandled pop up windows".

It is a needle used in the check_firefox_popups()[0] function and is supposed to match after the tracking info pop up bubble and reader view bubble have been handled, to make sure that there is no open pop up window left. The matching area therefore mainly focuses on the parts of the address bar where the track info symbol (a little shield) and the reader view symbol (an open book) are situated, which is at the left and right end of the address bar, respectively.

The circumstances however can vary greatly, because the pop up windows appear very randomly, and sometimes they do not show up at all, depending on the content of the site which can greatly differ day by day.

  • Where the reader view pop up has shown, and has been handled correctly, the firefox_clean needle matches an open book symbol and a little bit of an empty space underneath, to ascertain that there is no pop up bubble left
  • Similarly for the tracking protection pop up, the firefox_clean needle matches the little shield symbol and a small portion of an empty part underneath it, where the pop up bubble was
  • In case one (or both) of the pop up windows have not turned up, there will be neither shield nor book, therefore the needle comprises the left and right end of the address bar without the shield and book symbols. This is the case where the needle gets a bit messy because these areas (especially the left side) may contain various symbols in various combinations (the circled i, the plugin symbol, the green lock, the crossed grey lock...)

[0] https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/748aafe85453fd869a7eee585c81218ef0ce3106/lib/x11regressiontest.pm

#2 Updated by dimstar about 5 years ago

Thanks - so based on this description, I added one more needle for firefox_clean with the 'plugin' symbol in the tray... this should then hopefully make firefox_java pass too; test is restarted

#3 Updated by okurz about 5 years ago

  • Subject changed from firefox_java: define needles for 'firefox_clean' to [opensuse]firefox_java: define needles for 'firefox_clean'
  • Category set to Bugs in existing tests

#4 Updated by dimstar about 5 years ago

  • Status changed from New to Closed

Info was clear - needles for Java-9 based FF screens are in place, Java-9 test passed

Confirmation run: https://openqa.opensuse.org/tests/492200

Also available in: Atom PDF